summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-04-25 22:02:58 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-04-25 22:10:25 +0100
commit3079294a63fae24c16c089c6a8e56151ed62a99d (patch)
treec26abd15f70e26818df5c8ae8ef91f4896c9ffd9 /dev-libs/weston
parentdev-util/ruff: add 0.4.2, drop 0.4.1 (diff)
downloadgentoo-3079294a63fae24c16c089c6a8e56151ed62a99d.tar.gz
gentoo-3079294a63fae24c16c089c6a8e56151ed62a99d.tar.bz2
gentoo-3079294a63fae24c16c089c6a8e56151ed62a99d.zip
dev-libs/weston: Patch to build against neatvnc 0.8
Closes: https://bugs.gentoo.org/930424 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-libs/weston')
-rw-r--r--dev-libs/weston/files/weston-neatvnc-0.8.patch15
-rw-r--r--dev-libs/weston/weston-13.0.0-r2.ebuild (renamed from dev-libs/weston/weston-13.0.0-r1.ebuild)6
-rw-r--r--dev-libs/weston/weston-9999.ebuild6
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-libs/weston/files/weston-neatvnc-0.8.patch b/dev-libs/weston/files/weston-neatvnc-0.8.patch
new file mode 100644
index 000000000000..03ffab596c3a
--- /dev/null
+++ b/dev-libs/weston/files/weston-neatvnc-0.8.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/930424
+https://gitlab.freedesktop.org/wayland/weston/-/issues/890
+
+diff -Naur a/libweston/backend-vnc/meson.build b/libweston/backend-vnc/meson.build
+--- a/libweston/backend-vnc/meson.build 2023-11-27 18:01:53.000000000 +0000
++++ b/libweston/backend-vnc/meson.build 2024-04-24 23:55:22.262121014 +0100
+@@ -3,7 +3,7 @@
+ endif
+
+ config_h.set('BUILD_VNC_COMPOSITOR', '1')
+-dep_neatvnc = dependency('neatvnc', version: ['>= 0.7.0', '< 0.8.0'], required: false, fallback: ['neatvnc', 'neatvnc_dep'])
++dep_neatvnc = dependency('neatvnc', version: ['>= 0.7.0', '< 0.9.0'], required: false, fallback: ['neatvnc', 'neatvnc_dep'])
+ if not dep_neatvnc.found()
+ error('VNC backend requires neatvnc which was not found. Or, you can use \'-Dbackend-vnc=false\'.')
+ endif
diff --git a/dev-libs/weston/weston-13.0.0-r1.ebuild b/dev-libs/weston/weston-13.0.0-r2.ebuild
index 9b26690ae48b..659b66c2d03d 100644
--- a/dev-libs/weston/weston-13.0.0-r1.ebuild
+++ b/dev-libs/weston/weston-13.0.0-r2.ebuild
@@ -67,7 +67,7 @@ RDEPEND="
systemd? ( sys-apps/systemd )
vnc? (
=dev-libs/aml-0.3*
- =gui-libs/neatvnc-0.7*
+ =gui-libs/neatvnc-0.8*
sys-libs/pam
)
webp? ( media-libs/libwebp:0= )
@@ -93,6 +93,10 @@ BDEPEND="
$(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-neatvnc-0.8.patch
+)
+
python_check_deps() {
python_has_version "dev-python/setuptools[${PYTHON_USEDEP}]"
}
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 9b26690ae48b..659b66c2d03d 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -67,7 +67,7 @@ RDEPEND="
systemd? ( sys-apps/systemd )
vnc? (
=dev-libs/aml-0.3*
- =gui-libs/neatvnc-0.7*
+ =gui-libs/neatvnc-0.8*
sys-libs/pam
)
webp? ( media-libs/libwebp:0= )
@@ -93,6 +93,10 @@ BDEPEND="
$(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-neatvnc-0.8.patch
+)
+
python_check_deps() {
python_has_version "dev-python/setuptools[${PYTHON_USEDEP}]"
}