summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-01 23:01:05 +0000
committerSam James <sam@gentoo.org>2021-03-01 23:35:59 +0000
commitf5779182f8a4a46ee073f783c0eea3e7145e2551 (patch)
treecf04b193490c0bb50ffad91a0560a19fc592e3c8 /dev-libs/uthash
parentdev-db/spatialite-tools: bump to 5.0.1 (diff)
downloadgentoo-f5779182f8a4a46ee073f783c0eea3e7145e2551.tar.gz
gentoo-f5779182f8a4a46ee073f783c0eea3e7145e2551.tar.bz2
gentoo-f5779182f8a4a46ee073f783c0eea3e7145e2551.zip
dev-libs/uthash: Version updated to 2.3.0.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/19727 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/uthash')
-rw-r--r--dev-libs/uthash/Manifest1
-rw-r--r--dev-libs/uthash/uthash-2.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/uthash/Manifest b/dev-libs/uthash/Manifest
index 497c75a7ce4f..321f9897be0d 100644
--- a/dev-libs/uthash/Manifest
+++ b/dev-libs/uthash/Manifest
@@ -1 +1,2 @@
DIST uthash-2.2.0.tar.gz 191356 BLAKE2B ca07634c30f49fa21af5fed9ed254351d038ca9f831b2c3f3fb545ee451833aaec9e1666572635e2fd31d6b791fb88800e7d870aba2cda0cfbeddcba20d969a9 SHA512 441ee907adc39c9b7e9c1f478966b7e8ddebb94cb6d5db9d2db409aee9a5e237033ee8cef3fed1c719fea01c7cfb5991554ac89f5a1e59241bd5c6eb4854cebe
+DIST uthash-2.3.0.tar.gz 191291 BLAKE2B 473e263df9f3555c9ef41c2b39cf2ed33a4624ce7325bbe52db805ac741b8383e64f84a9e249f96faf40e0b94fa4a7fc6c0e83bebe8b3677a90cdca82a4e3f51 SHA512 3b01f1074790fb242900411cb16eb82c1a9afcf58e3196a0f4611d9d7ef94690ad38c0a500e7783d3efa20328aa8d6ab14f246be63b3b3d385502ba2b6b2a294
diff --git a/dev-libs/uthash/uthash-2.3.0.ebuild b/dev-libs/uthash/uthash-2.3.0.ebuild
new file mode 100644
index 000000000000..5e4ed934d4cc
--- /dev/null
+++ b/dev-libs/uthash/uthash-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="https://troydhanson.github.io/uthash/index.html"
+SRC_URI="https://github.com/troydhanson/uthash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/perl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-cflags.patch
+)
+
+src_test() {
+ cd tests || die
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ doheader src/*.h
+ dodoc doc/*.txt
+}