summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-07 06:51:15 +0100
committerSam James <sam@gentoo.org>2024-07-07 07:05:11 +0100
commitda3ec61bf72224423cc9ca8aaf76785d84f1e077 (patch)
tree7d6146437bcd0f2e7a7c8b9c8d067ea1da086ed9 /dev-libs/libgcrypt
parentdev-db/timescaledb: add 2.15.3 (diff)
downloadgentoo-da3ec61bf72224423cc9ca8aaf76785d84f1e077.tar.gz
gentoo-da3ec61bf72224423cc9ca8aaf76785d84f1e077.tar.bz2
gentoo-da3ec61bf72224423cc9ca8aaf76785d84f1e077.zip
dev-libs/libgcrypt: filter-flags
The codebase had had various UB in the past IIRC, it's sensitive to optimisation, and it already forces some components to be built with -O0. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.2.ebuild8
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.3-r1.ebuild8
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.3-r2.ebuild8
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild8
4 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.2.ebuild
index 06b52ad4ddb6..9747d039fe02 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.2.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.2.ebuild
@@ -78,6 +78,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # Sensitive to optimisation; parts of the codebase are built with
+ # -O0 already. Don't risk it with UB.
+ strip-flags
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
if [[ ${CHOST} == *86*-solaris* ]] ; then
# ASM code uses GNU ELF syntax, divide in particular, we need to
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.3-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.3-r1.ebuild
index 5d8b88fc0846..e2225f423866 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.3-r1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.3-r1.ebuild
@@ -81,6 +81,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # Sensitive to optimisation; parts of the codebase are built with
+ # -O0 already. Don't risk it with UB.
+ strip-flags
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
if [[ ${CHOST} == *86*-solaris* ]] ; then
# ASM code uses GNU ELF syntax, divide in particular, we need to
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.3-r2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.3-r2.ebuild
index 7b2ed8bd2e29..38eb6264d7e6 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.3-r2.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.3-r2.ebuild
@@ -84,6 +84,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # Sensitive to optimisation; parts of the codebase are built with
+ # -O0 already. Don't risk it with UB.
+ strip-flags
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
if [[ ${CHOST} == *86*-solaris* ]] ; then
# ASM code uses GNU ELF syntax, divide in particular, we need to
diff --git a/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild b/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild
index 9e28b00286b3..f3520b916d93 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild
@@ -85,6 +85,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # Sensitive to optimisation; parts of the codebase are built with
+ # -O0 already. Don't risk it with UB.
+ strip-flags
+
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
if [[ ${CHOST} == *86*-solaris* ]] ; then
# ASM code uses GNU ELF syntax, divide in particular, we need to