summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-03-06 15:46:32 -0500
committerDavid Seifert <soap@gentoo.org>2017-03-07 22:56:58 +0100
commita7bb963c619741bbc4e00331c93fb50f60f1faef (patch)
tree08c922700a506f21d34d197b2c13034511dcb8b9 /dev-libs/libfmt
parentdev-java/icedtea-bin: Version bump to 7.2.6.9 wrt security bug #609562 (diff)
downloadgentoo-a7bb963c619741bbc4e00331c93fb50f60f1faef.tar.gz
gentoo-a7bb963c619741bbc4e00331c93fb50f60f1faef.tar.bz2
gentoo-a7bb963c619741bbc4e00331c93fb50f60f1faef.zip
dev-libs/libfmt: Small, safe and fast formatting library
Bug: https://bugs.gentoo.org/show_bug.cgi?id=611804 Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4143
Diffstat (limited to 'dev-libs/libfmt')
-rw-r--r--dev-libs/libfmt/Manifest1
-rw-r--r--dev-libs/libfmt/libfmt-3.0.1.ebuild33
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild33
-rw-r--r--dev-libs/libfmt/metadata.xml16
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/libfmt/Manifest b/dev-libs/libfmt/Manifest
new file mode 100644
index 000000000000..ed842be51a85
--- /dev/null
+++ b/dev-libs/libfmt/Manifest
@@ -0,0 +1 @@
+DIST libfmt-3.0.1.tar.gz 606603 SHA256 dce62ab75a161dd4353a98364feb166d35e7eea382169d59d9ce842c49c55bad SHA512 daf5dfb2fe63eb611983fa248bd2182c6202cf1c4f0fc236f357040fce8e87ad531cdf59090306bb313ea333d546e516f467b385e05094e696d0ca091310aad6 WHIRLPOOL 775f9dc9228fbd429e4dbad90d536b69542fb583e44dba9eda950267bae82938b2703726481ff02fbab0cb9efe78b46501f4b82e20cfef550313b7653f6cb963
diff --git a/dev-libs/libfmt/libfmt-3.0.1.ebuild b/dev-libs/libfmt/libfmt-3.0.1.ebuild
new file mode 100644
index 000000000000..aa04d6331efe
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
new file mode 100644
index 000000000000..aa04d6331efe
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libfmt/metadata.xml b/dev-libs/libfmt/metadata.xml
new file mode 100644
index 000000000000..7891bb997fa2
--- /dev/null
+++ b/dev-libs/libfmt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@integralblue.com</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/fmtlib/fmt/issues</bugs-to>
+ <remote-id type="github">fmtlib/fmt</remote-id>
+ </upstream>
+</pkgmetadata>