summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-01 08:47:37 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-03 23:01:33 +0100
commitc815968c1a12eaff2b988a6759effb07d3f31631 (patch)
tree02855390bbb660cd5067ea36f0eb1c2339b9e420 /dev-libs/libdivsufsort
parentdev-perl/Params-Validate: Stable for HPPA (bug #579866). (diff)
downloadgentoo-c815968c1a12eaff2b988a6759effb07d3f31631.tar.gz
gentoo-c815968c1a12eaff2b988a6759effb07d3f31631.tar.bz2
gentoo-c815968c1a12eaff2b988a6759effb07d3f31631.zip
dev-libs/libdivsufsort: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libdivsufsort')
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild6
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
index 91f1f29db53c..c3e0840ad0b1 100644
--- a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
+++ b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils multilib
DESCRIPTION="Suffix-sorting library (for BWT)"
@@ -15,6 +15,8 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
src_prepare() {
+ cmake-utils_src_prepare
+
# will appreciate saner approach, if there is any
sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
*/CMakeLists.txt || die
diff --git a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
index 53e5951a1206..142c77a7d431 100644
--- a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
+++ b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils multilib
#if LIVE
@@ -25,6 +25,8 @@ SRC_URI=
#endif
src_prepare() {
+ cmake-utils_src_prepare
+
# will appreciate saner approach, if there is any
sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
*/CMakeLists.txt || die