summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libcoyotl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libcoyotl')
-rw-r--r--dev-libs/libcoyotl/Manifest1
-rw-r--r--dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch32
-rw-r--r--dev-libs/libcoyotl/files/3.1.0-gcc-4.7.patch11
-rw-r--r--dev-libs/libcoyotl/libcoyotl-3.1.0-r2.ebuild51
-rw-r--r--dev-libs/libcoyotl/metadata.xml5
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-libs/libcoyotl/Manifest b/dev-libs/libcoyotl/Manifest
new file mode 100644
index 000000000000..27d1a8dfed1c
--- /dev/null
+++ b/dev-libs/libcoyotl/Manifest
@@ -0,0 +1 @@
+DIST libcoyotl-3.1.0.tar.gz 346384 SHA256 540cb2e131cc345f94eaa1a7682532e200b57efd6b6a5e2d9e68aa7819f63860 SHA512 18d0a71204dc57d44f73fe03fd88c2a040e83615557cf1f018c22ad7c9a11d793c7f71df8e10a156b9fd4fae910882ed6cec37f9e57efd3546ffc15fa82a51b5 WHIRLPOOL 66a08ae5827ce9bf7ab5d532dc29485fc4b82e15005cad5a91f1e9fbc27b9fdd64889d0c9f68bbc7e7fd6463b6dcee552ed906c149bb6727f01931c213404ca4
diff --git a/dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch b/dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch
new file mode 100644
index 000000000000..4d3391e21161
--- /dev/null
+++ b/dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch
@@ -0,0 +1,32 @@
+diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp libcoyotl-3.1.0/libcoyotl/command_line.cpp
+--- libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp 2008-03-21 22:41:41.000000000 +0100
++++ libcoyotl-3.1.0/libcoyotl/command_line.cpp 2008-03-21 22:41:59.000000000 +0100
+@@ -30,10 +30,13 @@
+ // http://www.coyotegulch.com
+ //
+ //-----------------------------------------------------------------------
+
+ #include "command_line.h"
++
++#include <cstring>
++
+ using namespace libcoyotl;
+
+ command_line::command_line(int argc, char * argv[], const set<string> & bool_opts)
+ : m_options(),
+ m_inputs(),
+diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/sortutil.h libcoyotl-3.1.0/libcoyotl/sortutil.h
+--- libcoyotl-3.1.0.orig/libcoyotl/sortutil.h 2008-03-21 22:41:41.000000000 +0100
++++ libcoyotl-3.1.0/libcoyotl/sortutil.h 2008-03-21 22:41:59.000000000 +0100
+@@ -34,10 +34,11 @@
+ //-----------------------------------------------------------------------
+
+ #if !defined(LIBCOYOTL_SORTUTIL_H)
+ #define LIBCOYOTL_SORTUTIL_H
+
++#include <climits>
+ #include <stdexcept>
+
+ namespace libcoyotl
+ {
+
diff --git a/dev-libs/libcoyotl/files/3.1.0-gcc-4.7.patch b/dev-libs/libcoyotl/files/3.1.0-gcc-4.7.patch
new file mode 100644
index 000000000000..443cbe2a8657
--- /dev/null
+++ b/dev-libs/libcoyotl/files/3.1.0-gcc-4.7.patch
@@ -0,0 +1,11 @@
+--- libcoyotl/maze_renderer.cpp.ORIG 2005-10-10 06:48:30.000000000 +0200
++++ libcoyotl/maze_renderer.cpp 2013-04-12 10:29:31.127689828 +0200
+@@ -36,6 +36,8 @@
+ #include "maze_renderer.h"
+ using namespace libcoyotl;
+
++#include <string.h>
++
+ #include <stdexcept>
+ using namespace std;
+
diff --git a/dev-libs/libcoyotl/libcoyotl-3.1.0-r2.ebuild b/dev-libs/libcoyotl/libcoyotl-3.1.0-r2.ebuild
new file mode 100644
index 000000000000..7159b000282a
--- /dev/null
+++ b/dev-libs/libcoyotl/libcoyotl-3.1.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A collection of portable C++ classes"
+HOMEPAGE="http://www.coyotegulch.com/products/libcoyotl/"
+SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc static-libs"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gcc-4.3.patch"
+ epatch "${FILESDIR}/${PV}-gcc-4.7.patch"
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ ac_cv_prog_HAVE_DOXYGEN="false" econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ cd docs
+ doxygen libcoyotl.doxygen || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ if use doc ; then
+ dohtml docs/html/*
+ fi
+}
diff --git a/dev-libs/libcoyotl/metadata.xml b/dev-libs/libcoyotl/metadata.xml
new file mode 100644
index 000000000000..8434377a6047
--- /dev/null
+++ b/dev-libs/libcoyotl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cpp</herd>
+</pkgmetadata>