summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-06 20:40:17 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-06 20:40:17 +0100
commit6f5142d53f4456f0c3d653b954f62ed5488f328d (patch)
tree371fb3425f4df13b042b09d86eee8b73e481b580 /dev-libs/cudnn-frontend/cudnn-frontend-1.6.1.ebuild
parentdev-libs/cpuinfo: add 2024.10.22 drop 2022.08.19 2023.01.13 2022.03.26 (diff)
downloadgentoo-6f5142d53f4456f0c3d653b954f62ed5488f328d.tar.gz
gentoo-6f5142d53f4456f0c3d653b954f62ed5488f328d.tar.bz2
gentoo-6f5142d53f4456f0c3d653b954f62ed5488f328d.zip
dev-libs/cudnn-frontend: add 1.6.1 drop 0.6.2 0.7.3 0.9.2 1.1.2 1.0.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-libs/cudnn-frontend/cudnn-frontend-1.6.1.ebuild')
-rw-r--r--dev-libs/cudnn-frontend/cudnn-frontend-1.6.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/cudnn-frontend/cudnn-frontend-1.6.1.ebuild b/dev-libs/cudnn-frontend/cudnn-frontend-1.6.1.ebuild
new file mode 100644
index 000000000000..10648668e6c9
--- /dev/null
+++ b/dev-libs/cudnn-frontend/cudnn-frontend-1.6.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A c++ wrapper for the cudnn backend API"
+HOMEPAGE="https://github.com/NVIDIA/cudnn-frontend"
+SRC_URI="https://github.com/NVIDIA/cudnn-frontend/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/8"
+KEYWORDS="~amd64"
+
+RDEPEND="=dev-libs/cudnn-8*"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ insinto /opt/cuda/targets/x86_64-linux
+ doins -r include
+}