summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-24 09:53:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-24 09:57:30 +0300
commitd3887e9f15fade5c6dbbd79a11bb5a54a3e18c6a (patch)
treea9fb87a7bc19446bf827373d631b80d27e9ebf8c /dev-libs/crc32c
parentsys-apps/systemd: add 249.5 (diff)
downloadgentoo-d3887e9f15fade5c6dbbd79a11bb5a54a3e18c6a.tar.gz
gentoo-d3887e9f15fade5c6dbbd79a11bb5a54a3e18c6a.tar.bz2
gentoo-d3887e9f15fade5c6dbbd79a11bb5a54a3e18c6a.zip
dev-libs/crc32c: fix for arm64 without crc32
On arm64, the build system decided if the current CPU supports crc32 instructions, but forcing the compiler to support it and then checking if it compiles. By removing the forcing, we really check if the arch supports it. Bit thanks to Sam James <sam@gentoo.org> for testing and finding the issue in build system. Closes: https://bugs.gentoo.org/818874 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs/crc32c')
-rw-r--r--dev-libs/crc32c/crc32c-1.1.2-r1.ebuild (renamed from dev-libs/crc32c/crc32c-1.1.2.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-libs/crc32c/crc32c-1.1.2.ebuild b/dev-libs/crc32c/crc32c-1.1.2-r1.ebuild
index 6eee30bb278d..e7e06e01ec2a 100644
--- a/dev-libs/crc32c/crc32c-1.1.2.ebuild
+++ b/dev-libs/crc32c/crc32c-1.1.2-r1.ebuild
@@ -24,7 +24,9 @@ PATCHES=(
DOCS=( README.md )
src_prepare() {
- sed -e '/-Werror/d' -i CMakeLists.txt || die
+ sed -e '/-Werror/d' \
+ -e '/-march=armv8/d' \
+ -i CMakeLists.txt || die
cmake_src_prepare
}