summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-16 17:31:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-16 17:31:56 +0200
commitfc8b4b98c7c7dd6f349d319c6352dbe57645ffd5 (patch)
tree700c3297f69e004ebb176467ce0d979ad3a10fed /dev-lang
parentdev-lang/python: Add freethreaded 3.14.0_alpha1-r100 (diff)
downloadgentoo-fc8b4b98c7c7dd6f349d319c6352dbe57645ffd5.tar.gz
gentoo-fc8b4b98c7c7dd6f349d319c6352dbe57645ffd5.tar.bz2
gentoo-fc8b4b98c7c7dd6f349d319c6352dbe57645ffd5.zip
dev-lang/python: Override TMPDIR to reduce risk of test failures
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.15_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.11.10_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.7_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0.ebuild2
-rw-r--r--dev-lang/python/python-3.8.20_p2.ebuild1
-rw-r--r--dev-lang/python/python-3.9.20_p1.ebuild2
7 files changed, 13 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.15_p1.ebuild b/dev-lang/python/python-3.10.15_p1.ebuild
index d17f9d379036..e585b9e454a9 100644
--- a/dev-lang/python/python-3.10.15_p1.ebuild
+++ b/dev-lang/python/python-3.10.15_p1.ebuild
@@ -459,6 +459,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -493,6 +494,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.11.10_p1.ebuild b/dev-lang/python/python-3.11.10_p1.ebuild
index 7e4af08d8e21..3fc2272abc67 100644
--- a/dev-lang/python/python-3.11.10_p1.ebuild
+++ b/dev-lang/python/python-3.11.10_p1.ebuild
@@ -469,6 +469,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -508,6 +509,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.12.7_p1.ebuild b/dev-lang/python/python-3.12.7_p1.ebuild
index 16691eb29cef..9c7d3c48d9a7 100644
--- a/dev-lang/python/python-3.12.7_p1.ebuild
+++ b/dev-lang/python/python-3.12.7_p1.ebuild
@@ -466,6 +466,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -505,6 +506,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.13.0-r100.ebuild b/dev-lang/python/python-3.13.0-r100.ebuild
index 198705beb734..6c37fb5a26d7 100644
--- a/dev-lang/python/python-3.13.0-r100.ebuild
+++ b/dev-lang/python/python-3.13.0-r100.ebuild
@@ -513,6 +513,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -552,6 +553,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.13.0.ebuild b/dev-lang/python/python-3.13.0.ebuild
index ffd6571fce4b..6dcbf03f0712 100644
--- a/dev-lang/python/python-3.13.0.ebuild
+++ b/dev-lang/python/python-3.13.0.ebuild
@@ -514,6 +514,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -553,6 +554,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.8.20_p2.ebuild b/dev-lang/python/python-3.8.20_p2.ebuild
index 3d8191354d82..7510f63d792b 100644
--- a/dev-lang/python/python-3.8.20_p2.ebuild
+++ b/dev-lang/python/python-3.8.20_p2.ebuild
@@ -387,6 +387,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.9.20_p1.ebuild b/dev-lang/python/python-3.9.20_p1.ebuild
index 8ef53f8d24dd..3113665f544f 100644
--- a/dev-lang/python/python-3.9.20_p1.ebuild
+++ b/dev-lang/python/python-3.9.20_p1.ebuild
@@ -445,6 +445,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -479,6 +480,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty