summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-14 17:00:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-14 17:29:05 +0100
commitcba81ae61e4fb5b260f91a540a1988e9091768f2 (patch)
treebafe67d0492438e884f2eba4306b7ab809a1cb7c /dev-lang
parentdev-perl/Module-Info: EAPI=8 bump (diff)
downloadgentoo-cba81ae61e4fb5b260f91a540a1988e9091768f2.tar.gz
gentoo-cba81ae61e4fb5b260f91a540a1988e9091768f2.tar.bz2
gentoo-cba81ae61e4fb5b260f91a540a1988e9091768f2.zip
dev-lang/python: Force stdlib distutils for build
Closes: https://bugs.gentoo.org/823728 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.0_p1.ebuild3
-rw-r--r--dev-lang/python/python-3.11.0_alpha1.ebuild3
-rw-r--r--dev-lang/python/python-3.11.0_alpha2.ebuild3
-rw-r--r--dev-lang/python/python-3.8.12_p1.ebuild3
-rw-r--r--dev-lang/python/python-3.9.7_p1.ebuild3
-rw-r--r--dev-lang/python/python-3.9.8.ebuild3
6 files changed, 18 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.0_p1.ebuild b/dev-lang/python/python-3.10.0_p1.ebuild
index 150a33f5b6b6..2bc9d2d3e7e7 100644
--- a/dev-lang/python/python-3.10.0_p1.ebuild
+++ b/dev-lang/python/python-3.10.0_p1.ebuild
@@ -193,6 +193,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=
diff --git a/dev-lang/python/python-3.11.0_alpha1.ebuild b/dev-lang/python/python-3.11.0_alpha1.ebuild
index c69b8cd0966f..65770c78aa4f 100644
--- a/dev-lang/python/python-3.11.0_alpha1.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha1.ebuild
@@ -193,6 +193,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=
diff --git a/dev-lang/python/python-3.11.0_alpha2.ebuild b/dev-lang/python/python-3.11.0_alpha2.ebuild
index fd039096d637..9b3ea1304095 100644
--- a/dev-lang/python/python-3.11.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha2.ebuild
@@ -194,6 +194,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=
diff --git a/dev-lang/python/python-3.8.12_p1.ebuild b/dev-lang/python/python-3.8.12_p1.ebuild
index a95b30f11b9d..ff54e4402ebc 100644
--- a/dev-lang/python/python-3.8.12_p1.ebuild
+++ b/dev-lang/python/python-3.8.12_p1.ebuild
@@ -179,6 +179,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=
diff --git a/dev-lang/python/python-3.9.7_p1.ebuild b/dev-lang/python/python-3.9.7_p1.ebuild
index 3af399c076aa..68e7ee9cc370 100644
--- a/dev-lang/python/python-3.9.7_p1.ebuild
+++ b/dev-lang/python/python-3.9.7_p1.ebuild
@@ -190,6 +190,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=
diff --git a/dev-lang/python/python-3.9.8.ebuild b/dev-lang/python/python-3.9.8.ebuild
index 796265447e81..503166ee6fcb 100644
--- a/dev-lang/python/python-3.9.8.ebuild
+++ b/dev-lang/python/python-3.9.8.ebuild
@@ -191,6 +191,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=