summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-02 13:57:17 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-02 14:03:20 -0700
commitb37dece3267ea2c18016c66180b57dc7573e384a (patch)
tree8e90c7b7a92ec96a602dbf26a686023f393dd405 /dev-lang
parentdev-libs/ell: drop desc for removed glib flag (diff)
downloadgentoo-b37dece3267ea2c18016c66180b57dc7573e384a.tar.gz
gentoo-b37dece3267ea2c18016c66180b57dc7573e384a.tar.bz2
gentoo-b37dece3267ea2c18016c66180b57dc7573e384a.zip
dev-lang/rust-bin: add QA_EXECSTACK for rmeta sections
Bug: https://bugs.gentoo.org/806466 Closes: https://bugs.gentoo.org/806468 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.52.1.ebuild5
-rw-r--r--dev-lang/rust-bin/rust-bin-1.53.0.ebuild5
-rw-r--r--dev-lang/rust-bin/rust-bin-1.54.0.ebuild5
-rw-r--r--dev-lang/rust-bin/rust-bin-1.55.0.ebuild5
-rw-r--r--dev-lang/rust-bin/rust-bin-1.56.0.ebuild5
-rw-r--r--dev-lang/rust-bin/rust-bin-1.56.1.ebuild5
6 files changed, 30 insertions, 0 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.52.1.ebuild b/dev-lang/rust-bin/rust-bin-1.52.1.ebuild
index 8ae41adca726..74e467bd616b 100644
--- a/dev-lang/rust-bin/rust-bin-1.52.1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.52.1.ebuild
@@ -33,6 +33,11 @@ QA_PREBUILT="
opt/${P}/lib/rustlib/.*/lib/.*
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
pkg_pretend() {
diff --git a/dev-lang/rust-bin/rust-bin-1.53.0.ebuild b/dev-lang/rust-bin/rust-bin-1.53.0.ebuild
index 8ae41adca726..74e467bd616b 100644
--- a/dev-lang/rust-bin/rust-bin-1.53.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.53.0.ebuild
@@ -33,6 +33,11 @@ QA_PREBUILT="
opt/${P}/lib/rustlib/.*/lib/.*
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
pkg_pretend() {
diff --git a/dev-lang/rust-bin/rust-bin-1.54.0.ebuild b/dev-lang/rust-bin/rust-bin-1.54.0.ebuild
index 64f7fa3d9544..2796cb0698b1 100644
--- a/dev-lang/rust-bin/rust-bin-1.54.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.54.0.ebuild
@@ -33,6 +33,11 @@ QA_PREBUILT="
opt/${P}/lib/rustlib/.*/lib/.*
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
pkg_pretend() {
diff --git a/dev-lang/rust-bin/rust-bin-1.55.0.ebuild b/dev-lang/rust-bin/rust-bin-1.55.0.ebuild
index 64f7fa3d9544..2796cb0698b1 100644
--- a/dev-lang/rust-bin/rust-bin-1.55.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.55.0.ebuild
@@ -33,6 +33,11 @@ QA_PREBUILT="
opt/${P}/lib/rustlib/.*/lib/.*
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
pkg_pretend() {
diff --git a/dev-lang/rust-bin/rust-bin-1.56.0.ebuild b/dev-lang/rust-bin/rust-bin-1.56.0.ebuild
index 64f7fa3d9544..2796cb0698b1 100644
--- a/dev-lang/rust-bin/rust-bin-1.56.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.56.0.ebuild
@@ -33,6 +33,11 @@ QA_PREBUILT="
opt/${P}/lib/rustlib/.*/lib/.*
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
pkg_pretend() {
diff --git a/dev-lang/rust-bin/rust-bin-1.56.1.ebuild b/dev-lang/rust-bin/rust-bin-1.56.1.ebuild
index 64f7fa3d9544..2796cb0698b1 100644
--- a/dev-lang/rust-bin/rust-bin-1.56.1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.56.1.ebuild
@@ -33,6 +33,11 @@ QA_PREBUILT="
opt/${P}/lib/rustlib/.*/lib/.*
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_EXECSTACK="opt/${P}/lib/rustlib/*/lib*.rlib:lib.rmeta"
+
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
pkg_pretend() {