summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-03 17:46:01 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-03 20:44:36 +0200
commit083463d231de844ed42ca79bc390c54f2bc1b6aa (patch)
tree5d8e7c8834bf8c61387d75a70ac5cd0c04624edb /dev-lang/kotlin-bin
parentdev-lang/kotlin-bin: drop old 2.0.0 (diff)
downloadgentoo-083463d231de844ed42ca79bc390c54f2bc1b6aa.tar.gz
gentoo-083463d231de844ed42ca79bc390c54f2bc1b6aa.tar.bz2
gentoo-083463d231de844ed42ca79bc390c54f2bc1b6aa.zip
dev-lang/kotlin-bin: bump to 2.0.20
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/kotlin-bin')
-rw-r--r--dev-lang/kotlin-bin/Manifest1
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
index 09f8d38fef85..323e2b9451f3 100644
--- a/dev-lang/kotlin-bin/Manifest
+++ b/dev-lang/kotlin-bin/Manifest
@@ -1 +1,2 @@
DIST kotlin-compiler-2.0.10.zip 83745882 BLAKE2B acd359e348fdb8fbb339a2fcd5fedb165990cc366f0c717644360267aa161e96b8813e0569a0ebc8f2d5de65f25c780c733b6b50c14e8b943344c31a492f0534 SHA512 ba0eac447eb62726604fe9f0d563b1fa8d23001f3ed6053954269e3f342886533a1fa2a8fc4d8f1e7aaae7b94db96a72f195f2b886eb7a50d1e6c25ac80ba106
+DIST kotlin-compiler-2.0.20.zip 86110157 BLAKE2B 601e6d8b0ac3af3b8b0b2ddc87bb8ab2d69769e9f3d217c1be317874bfd77a8b767fd84c315637b48782393326bc3b1abc875d1293b3766dc03a0216d26cddf0 SHA512 07bb47339813d127783b2ddfd52635dd483744f1821c8b95075698f37c506e0b66c7abb3d9ab183ba957fe07b4ce1a34b9be2c4477ca0e9115feacab8380bba7
diff --git a/dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild b/dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild
new file mode 100644
index 000000000000..7e3629cfadfc
--- /dev/null
+++ b/dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 wrapper
+
+DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
+HOMEPAGE="https://kotlinlang.org/
+ https://github.com/JetBrains/kotlin/"
+SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
+S="${WORKDIR}/kotlinc"
+
+LICENSE="Apache-2.0 BSD MIT NPL-1.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm bin/*.bat || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ # Follow the Java eclass JAR installation path.
+ local app_home="/usr/share/${PN}"
+
+ exeinto "${app_home}/bin"
+ doexe bin/*
+
+ local -a exes=(
+ kapt
+ kotlin
+ kotlinc
+ kotlinc-js
+ kotlinc-jvm
+ kotlin-dce-js
+ )
+ local exe
+ for exe in "${exes[@]}" ; do
+ make_wrapper "${exe}" "${app_home}/bin/${exe}"
+ done
+}