summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/laf-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/laf-plugin')
-rw-r--r--dev-java/laf-plugin/Manifest1
-rw-r--r--dev-java/laf-plugin/files/laf-plugin-0.2-build.xml46
-rw-r--r--dev-java/laf-plugin/laf-plugin-0.2.ebuild33
-rw-r--r--dev-java/laf-plugin/metadata.xml5
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-java/laf-plugin/Manifest b/dev-java/laf-plugin/Manifest
new file mode 100644
index 000000000000..102b809d13f5
--- /dev/null
+++ b/dev-java/laf-plugin/Manifest
@@ -0,0 +1 @@
+DIST laf-plugin-0.2-src.tar.bz2 13799 SHA256 e2252f74efbaa1f0c32a475c320283e614932e3af2d98a65462bf0e1f8cc00ba SHA512 91ac3f9f5ebfcd70e7cc76f2e028e9578c6113a848b0ccdc6b001fff006bf5aaa12af08b1752851693d218d4b2d7d053f62461481e49d5a0bde21e5a7d086331 WHIRLPOOL 6aaea36bbcc22eca1704185faf866fba1b723cd3d6ff02197f28287ded67fc43bb4c2f9cbe8a2dce9e82eaa88774b1fdb4c66e54cdc4f09ad946718641cb1334
diff --git a/dev-java/laf-plugin/files/laf-plugin-0.2-build.xml b/dev-java/laf-plugin/files/laf-plugin-0.2-build.xml
new file mode 100644
index 000000000000..fbcd199a4d9e
--- /dev/null
+++ b/dev-java/laf-plugin/files/laf-plugin-0.2-build.xml
@@ -0,0 +1,46 @@
+<project name="laf_plugin" default="dist" basedir=".">
+ <description>
+ Simple build file made by Alistair Bush for the kunststoff
+ project.
+ </description>
+
+ <property name="src" location="./src"/>
+ <property name="build" location="./build"/>
+ <property name="dist" location="./dist"/>
+ <property name="api" location="api"/>
+
+ <target name="init">
+ <tstamp/>
+ <mkdir dir="${build}"/>
+ <mkdir dir="${api}"/>
+ </target>
+
+ <target name="javadoc" depends="init" description="Produce JavaDoc">
+ <javadoc sourcepath="${src}" destdir="${api}"/>
+ </target>
+
+ <target name="compile" depends="init" description="compile the source">
+ <javac srcdir="${src}" destdir="${build}" >
+ <include name="**/*.java" />
+ </javac>
+ </target>
+
+ <target name="dist" depends="compile"
+ description="generate the distribution" >
+
+ <copy todir="build">
+ <fileset dir="src">
+ <exclude name="**/*.java"/>
+ </fileset>
+ </copy>
+ <mkdir dir="${dist}" />
+ <jar jarfile="${dist}/laf-plugin.jar" basedir="${build}"/>
+ </target>
+
+ <target name="clean" description="Clean up">
+ <delete dir="${build}" />
+ <delete dir="${dist}" />
+ <delete file="./*.jar" />
+ </target>
+
+</project>
diff --git a/dev-java/laf-plugin/laf-plugin-0.2.ebuild b/dev-java/laf-plugin/laf-plugin-0.2.ebuild
new file mode 100644
index 000000000000..51a034965a87
--- /dev/null
+++ b/dev-java/laf-plugin/laf-plugin-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A generic plugin framework for look-and-feels"
+HOMEPAGE="http://laf-plugin.dev.java.net/"
+# repackaged from zip and renamed to contain PV
+SRC_URI="mirror://gentoo/${P}-src.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cp "${FILESDIR}/${P}-build.xml" build.xml || die
+}
+
+EANT_BUILD_TARGET="dist"
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc src/org
+}
diff --git a/dev-java/laf-plugin/metadata.xml b/dev-java/laf-plugin/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/laf-plugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>