summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jscience
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jscience')
-rw-r--r--dev-java/jscience/Manifest1
-rw-r--r--dev-java/jscience/jscience-1.0.4-r1.ebuild47
-rw-r--r--dev-java/jscience/metadata.xml5
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/jscience/Manifest b/dev-java/jscience/Manifest
new file mode 100644
index 000000000000..ff0f6a73d119
--- /dev/null
+++ b/dev-java/jscience/Manifest
@@ -0,0 +1 @@
+DIST jscience-1.0.4-src.zip 414755 SHA256 2ab5573ed2e3f0c8975dbf8ce118f1514f4a2e65d5960e7d210b6699790b0639 SHA512 d78b5cf32117d1f6638d00298185fb01dc1d710d38a1894ffa6ac0c436f6eefa6d330025b8d422597d0109b9ad06d3aa43cf6481bc1ebfad88677e14c1927956 WHIRLPOOL 466d5dc12e9402c70eda444afc9d832252b5e86b924470441d76ca0377b049ac6a0d969b21c7e361b6feb60d95dd9b4adb451048b1c310ddf22a76b4b451e67f
diff --git a/dev-java/jscience/jscience-1.0.4-r1.ebuild b/dev-java/jscience/jscience-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..9d73294c0045
--- /dev/null
+++ b/dev-java/jscience/jscience-1.0.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Tools and Libraries for the Advancement of Sciences"
+SRC_URI="http://jscience.org/${P}-src.zip"
+HOMEPAGE="http://jscience.org/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEP="~dev-java/javolution-2.2.4"
+
+RDEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/jscience-${PV%.*}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/lib"
+ rm -v *.jar || die
+ java-pkg_jar-from javolution-2.2.4
+}
+
+EANT_BUILD_TARGET="jarfile"
+
+src_test() {
+ # this works here as javolution is in lib/ and referenced in jar's manifest
+ java -jar jscience.jar test || die "test failed"
+}
+
+src_install() {
+ java-pkg_dojar jscience.jar
+
+ dodoc doc/coding_standard.txt || die
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc "${S}/src/org"
+}
diff --git a/dev-java/jscience/metadata.xml b/dev-java/jscience/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/jscience/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>