summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-01-18 10:57:31 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-18 10:57:31 +0100
commitd621e4a9e80c0220b643014776cd8be742e4f114 (patch)
tree224cbe14cf7f8fa3cbaf6abefb9b19ff2f6f0ad5 /dev-java/jansi
parentdev-java/jansi: LDFLAGS (diff)
downloadgentoo-d621e4a9e80c0220b643014776cd8be742e4f114.tar.gz
gentoo-d621e4a9e80c0220b643014776cd8be742e4f114.tar.bz2
gentoo-d621e4a9e80c0220b643014776cd8be742e4f114.zip
dev-java/jansi: removed obsolete 2.4.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jansi')
-rw-r--r--dev-java/jansi/jansi-2.4.0.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-java/jansi/jansi-2.4.0.ebuild b/dev-java/jansi/jansi-2.4.0.ebuild
deleted file mode 100644
index e93adc8efc55..000000000000
--- a/dev-java/jansi/jansi-2.4.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/fusesource/jansi/archive/refs/tags/jansi-2.4.0.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jansi-2.4.0.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="org.fusesource.jansi:jansi:2.4.0"
-
-inherit java-pkg-2 java-pkg-simple toolchain-funcs
-
-DESCRIPTION="Jansi is a java library for generating and interpreting ANSI escape sequences."
-HOMEPAGE="http://fusesource.github.io/jansi"
-SRC_URI="https://github.com/fusesource/${PN}/archive/refs/tags/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-# Compile dependencies
-# POM: pom.xml
-# test? info.picocli:picocli-codegen:4.5.2 -> !!!artifactId-not-found!!!
-# test? org.junit.jupiter:junit-jupiter:5.7.0 -> !!!groupId-not-found!!!
-# test? org.junit.jupiter:junit-jupiter-params:5.7.0 -> !!!groupId-not-found!!!
-
-DEPEND=">=virtual/jdk-1.8:*"
-
-# junit-jupiter is not available in ::gentoo
-# test? (
-# !!!artifactId-not-found!!!
-# !!!groupId-not-found!!!
-# )
-#"
-
-RDEPEND=">=virtual/jre-1.8:*"
-
-DOCS=( {changelog,readme}.md license.txt )
-
-S="${WORKDIR}/${PN}-${P}"
-
-JAVA_SRC_DIR="src/main/java"
-JAVA_RESOURCE_DIRS="src/main/resources"
-JAVA_MAIN_CLASS="org.fusesource.jansi.AnsiMain"
-
-# junit-jupiter is not available in ::gentoo
-#JAVA_TEST_GENTOO_CLASSPATH="!!!artifactId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!"
-#JAVA_TEST_SRC_DIR="src/test/java"
-#JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-
-src_prepare() {
- default
- # Remove this directory containing libjansi.so, libjansi.jnilib and jansi.dll
- rm -r "${JAVA_RESOURCE_DIRS}/org/fusesource/jansi/internal/native" || die
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-
- # build native library.
- local args=(
- CCFLAGS="${CFLAGS} ${CXXFLAGS} -Os -fPIC -fvisibility=hidden"
- LINKFLAGS="-shared"
- CC="$(tc-getCC)"
- STRIP="$(tc-getSTRIP)"
- LIBNAME="libjansi-$(ver_cut 1-2).so"
- )
- emake "${args[@]}" native
-}
-
-src_install() {
- # default # https://bugs.gentoo.org/789582
- # deafult fails with
- # make: *** No rule to make target 'install'. Stop.
- java-pkg_doso target/native--/libjansi-$(ver_cut 1-2).so
- java-pkg-simple_src_install
-}