summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/fec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/fec')
-rw-r--r--dev-java/fec/Manifest1
-rw-r--r--dev-java/fec/fec-1.0.4-r1.ebuild61
-rw-r--r--dev-java/fec/files/fec-1.0.4-build.patch32
-rw-r--r--dev-java/fec/files/fec-1.0.4-libfec8path.patch29
-rw-r--r--dev-java/fec/files/fec-1.0.4-soname.patch22
-rw-r--r--dev-java/fec/files/libfec8path.patch27
-rw-r--r--dev-java/fec/metadata.xml10
7 files changed, 182 insertions, 0 deletions
diff --git a/dev-java/fec/Manifest b/dev-java/fec/Manifest
new file mode 100644
index 000000000000..d85a1e356a5b
--- /dev/null
+++ b/dev-java/fec/Manifest
@@ -0,0 +1 @@
+DIST fec-1.0.4.tar.bz2 611131 SHA256 978d0ef609ec334ea85e3f70e46a94f6c2cc04393b590a2addfc74e03634b8dd SHA512 45e33fc4b71fcd78a7c5310f2b58df8b83a988500d0de7efebbeade712f5c93d57bbe63fd7dc148ccb1cc6418fc9c79e27be6fe0512e2294c289b192c01ab871 WHIRLPOOL cef5de5b24ddc33f6a85581cd149d3c5887f8f49843df5918158d137b263a58b888149fe68e293bc697db0b7b74e3952fabc1842f8b8f80932de379f2c7bf0d2
diff --git a/dev-java/fec/fec-1.0.4-r1.ebuild b/dev-java/fec/fec-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..089e66f337cb
--- /dev/null
+++ b/dev-java/fec/fec-1.0.4-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit flag-o-matic java-pkg-2 java-ant-2 toolchain-funcs
+
+DESCRIPTION="Forword error correction libs"
+HOMEPAGE="http://www.onionnetworks.com/developers/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/log4j
+ dev-java/concurrent-util"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+EANT_BUILD_TARGET="jars"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ sed -i -e 's/build.compiler=jikes/#build.compiler=jikes/g' build.properties || die
+ sed -i -e 's/test.lib/lib/g' build.properties || die
+ epatch "${FILESDIR}"/${P}-{libfec8path,build,soname}.patch
+
+ eant clean
+ cd lib || die
+ rm -v *.jar || die
+ java-pkg_jar-from log4j
+ java-pkg_jar-from concurrent-util concurrent.jar concurrent-jaxed.jar
+ cd "${S}" || die
+ unzip -q common-20020926.zip || die
+ cd common-20020926 || die
+ eant clean
+ cp -r src/com ../src/ || die
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd "${S}"/src/csrc
+ append-flags -fPIC
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS} $(java-pkg_get-jni-cflags)" || die
+}
+
+#there seem to be unit tests, but they are in such a state.
+
+src_install() {
+ java-pkg_newjar lib/onion-${PN}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/com
+ dolib.so src/csrc/libfec{8,16}.so || die
+}
diff --git a/dev-java/fec/files/fec-1.0.4-build.patch b/dev-java/fec/files/fec-1.0.4-build.patch
new file mode 100644
index 000000000000..3920dcec4c7d
--- /dev/null
+++ b/dev-java/fec/files/fec-1.0.4-build.patch
@@ -0,0 +1,32 @@
+Index: csrc/Makefile
+===================================================================
+--- src/csrc.orig/Makefile
++++ src/csrc/Makefile
+@@ -28,11 +28,8 @@ fec8-jinterf.o: fec-jinterf.c
+ -I$(JAVA_HOME)/include/linux fec-jinterf.c \
+ -o fec8-jinterf.o
+
+-fec8.o: fec.h fec8.S
+- $(CC) $(CFLAGS) -DGF_BITS=8 -c -o fec8.o fec8.S
+-
+-fec8.S: fec.c Makefile
+- $(CC) $(CFLAGS) -DGF_BITS=8 -S -o fec8.S fec.c
++fec8.o: fec.h fec.c
++ $(CC) $(CFLAGS) -DGF_BITS=8 -c -o fec8.o fec.c
+
+ libfec16.so: fec16.o fec16-jinterf.o
+ $(CC) $(LDFLAGS) -shared fec16-jinterf.o fec16.o -o libfec16.so
+@@ -42,11 +39,8 @@ fec16-jinterf.o: fec-jinterf.c
+ -I$(JAVA_HOME)/include/linux fec-jinterf.c \
+ -o fec16-jinterf.o
+
+-fec16.o: fec.h fec16.S
+- $(CC) $(CFLAGS) -DGF_BITS=16 -c -o fec16.o fec16.S
+-
+-fec16.S: fec.c Makefile
+- $(CC) $(CFLAGS) -DGF_BITS=16 -S -o fec16.S fec.c
++fec16.o: fec.h fec.c
++ $(CC) $(CFLAGS) -DGF_BITS=16 -c -o fec16.o fec.c
+
+ clean:
+ - rm -f *.o *.S fec *.so
diff --git a/dev-java/fec/files/fec-1.0.4-libfec8path.patch b/dev-java/fec/files/fec-1.0.4-libfec8path.patch
new file mode 100644
index 000000000000..503db7c837eb
--- /dev/null
+++ b/dev-java/fec/files/fec-1.0.4-libfec8path.patch
@@ -0,0 +1,29 @@
+--- src/com/onionnetworks/fec/Native8Code.java 2009-08-21 02:37:00.515004583 +0200
++++ src/com/onionnetworks/fec/Native8Code.java.new 2009-08-21 02:37:57.829254678 +0200
+@@ -3,6 +3,7 @@
+ //import java.security.AccessController;
+ //import sun.security.action.*;
+ import com.onionnetworks.util.*;
++import java.io.File;
+
+ /**
+ * This class is the frontend for the JNI wrapper for the C implementation of
+@@ -21,15 +22,10 @@
+ final private long code;
+
+ static {
+- String path = NativeDeployer.getLibraryPath
+- (Native8Code.class.getClassLoader(),"fec8");
+- if (path != null) {
+- System.load(path);
++ File path = new File("/usr/lib/libfec8.so");
++ System.out.println("Loading FEC lib ["+path.getAbsolutePath()+']');
++ System.load(path.getAbsolutePath());
+ initFEC();
+- } else {
+- System.out.println("Unable to find native library for fec8 for platform "+NativeDeployer.OS_ARCH);
+- System.out.println(path);
+- }
+ }
+
+ public Native8Code(int k, int n) {
diff --git a/dev-java/fec/files/fec-1.0.4-soname.patch b/dev-java/fec/files/fec-1.0.4-soname.patch
new file mode 100644
index 000000000000..ae00449ced40
--- /dev/null
+++ b/dev-java/fec/files/fec-1.0.4-soname.patch
@@ -0,0 +1,22 @@
+--- src/csrc/Makefile.bak 2010-02-27 00:51:38.000000000 +1300
++++ src/csrc/Makefile 2010-02-27 00:56:06.000000000 +1300
+@@ -21,7 +21,8 @@
+ $(CC) $(CFLAGS) -DGF_BITS=8 -o fec fec8.o test.c
+
+ libfec8.so: fec8.o fec8-jinterf.o
+- $(CC) $(LDFLAGS) -shared fec8-jinterf.o fec8.o -o libfec8.so
++ $(CC) $(LDFLAGS) -shared fec8-jinterf.o fec8.o -o libfec8.so \
++ -Wl,-soname=libfec8.so
+
+ fec8-jinterf.o: fec-jinterf.c
+ $(CC) $(CFLAGS) -DGF_BITS=8 -c \
+@@ -35,7 +36,8 @@
+ $(CC) $(CFLAGS) -DGF_BITS=8 -S -o fec8.S fec.c
+
+ libfec16.so: fec16.o fec16-jinterf.o
+- $(CC) $(LDFLAGS) -shared fec16-jinterf.o fec16.o -o libfec16.so
++ $(CC) $(LDFLAGS) -shared fec16-jinterf.o fec16.o -o libfec16.so \
++ -Wl,-soname=libfec16.so
+
+ fec16-jinterf.o: fec-jinterf.c
+ $(CC) $(CFLAGS) -DGF_BITS=16 -c \
diff --git a/dev-java/fec/files/libfec8path.patch b/dev-java/fec/files/libfec8path.patch
new file mode 100644
index 000000000000..928e3fec62d3
--- /dev/null
+++ b/dev-java/fec/files/libfec8path.patch
@@ -0,0 +1,27 @@
+--- src/com/onionnetworks/fec/Native8Code.java 2002-09-30 20:19:24.000000000 +0200
++++ src/com/onionnetworks/fec/Native8Code.java.new 2008-03-24 01:38:35.000000000 +0100
+@@ -3,6 +3,7 @@
+ //import java.security.AccessController;
+ //import sun.security.action.*;
+ import com.onionnetworks.util.*;
++import java.io.File;
+
+ /**
+ * This class is the frontend for the JNI wrapper for the C implementation of
+@@ -21,13 +22,9 @@
+ private int code;
+
+ static {
+- String path = NativeDeployer.getLibraryPath
+- (Native8Code.class.getClassLoader(),"fec8");
+- if (path != null) {
+- System.load(path);
+- } else {
+- System.out.println("Unable to find native library for fec8");
+- }
++ File path = new File("/usr/lib/libfec8.so");
++ System.out.println("Loading FEC lib ["+path.getAbsolutePath()+']');
++ System.load(path.getAbsolutePath());
+ }
+
+ public Native8Code(int k, int n) {
diff --git a/dev-java/fec/metadata.xml b/dev-java/fec/metadata.xml
new file mode 100644
index 000000000000..21237a6e3ed0
--- /dev/null
+++ b/dev-java/fec/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+ <herd>java</herd>
+</pkgmetadata>
+