summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:12 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:29 +0100
commite6a49e40019d19e8a6ce6399e7ed656941409642 (patch)
tree85e62f36842ba46f792402e9b705cc6c11369d06 /dev-haskell
parentdev-haskell/yaml: Migrate to CABAL_CHBINS (diff)
downloadgentoo-e6a49e40019d19e8a6ce6399e7ed656941409642.tar.gz
gentoo-e6a49e40019d19e8a6ce6399e7ed656941409642.tar.bz2
gentoo-e6a49e40019d19e8a6ce6399e7ed656941409642.zip
dev-haskell/yesod-core: add 1.6.24.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/yesod-core/Manifest1
-rw-r--r--dev-haskell/yesod-core/metadata.xml9
-rw-r--r--dev-haskell/yesod-core/yesod-core-1.6.24.2.ebuild59
3 files changed, 64 insertions, 5 deletions
diff --git a/dev-haskell/yesod-core/Manifest b/dev-haskell/yesod-core/Manifest
index 7d6e5af38e07..76f6b17bb8c3 100644
--- a/dev-haskell/yesod-core/Manifest
+++ b/dev-haskell/yesod-core/Manifest
@@ -1 +1,2 @@
DIST yesod-core-1.6.23.1.tar.gz 103119 BLAKE2B a15ee64ddc5da8f531690b8d6b661af618754a44e3e3511f15af69d82a53ce6d7886a4b55243d611727c2618446a145469db27b9ba122a32bd538d8cf6abdf80 SHA512 edbdf46c2a04a7286d46030212dcbb2c7f0e0e8b62e87682ae8ed4468796d15544990fb43d56a801fcfbf4dde740bc09cfa192ec21c3d5aeb72b92a5ed0cb173
+DIST yesod-core-1.6.24.2.tar.gz 104045 BLAKE2B fa18b345d97bf791275efca6a3e92f5c82fd1651391211669a2919d9a1b1ef896db5ca3fee80ae7d65a0f540a08e7eeca90ec25b524095fce5b480a02daf6bc7 SHA512 d75431871d3b38b78ca220a602ac44894c1142345588707591bacb9590ca98d4706285377d91e78e61e84050b55b2c96c0a308c4d84d2779d5fccb318f451ef3
diff --git a/dev-haskell/yesod-core/metadata.xml b/dev-haskell/yesod-core/metadata.xml
index 3f36fda0e30c..9e6066177c58 100644
--- a/dev-haskell/yesod-core/metadata.xml
+++ b/dev-haskell/yesod-core/metadata.xml
@@ -5,9 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Yesod is a framework designed to foster creation of RESTful web application that have strong compile-time guarantees of correctness. It also affords space efficient code and portability to many deployment backends, from CGI to stand-alone serving.
-
- The Yesod documentation site &lt;http://www.yesodweb.com/&gt; has much more information, tutorials and information on some of the supporting packages, like Hamlet and Persistent.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">yesod-core</remote-id>
+ <remote-id type="github">yesodweb/yesod</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/yesod-core/yesod-core-1.6.24.2.ebuild b/dev-haskell/yesod-core/yesod-core-1.6.24.2.ebuild
new file mode 100644
index 000000000000..4b9c5e3ecdc0
--- /dev/null
+++ b/dev-haskell/yesod-core/yesod-core-1.6.24.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ dev-haskell/auto-update:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.7.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/clientsession-0.9.1:=[profile?] <dev-haskell/clientsession-0.10:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ >=dev-haskell/cookie-0.4.3:=[profile?] <dev-haskell/cookie-0.5:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/fast-logger-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/monad-logger-0.3.10:=[profile?] <dev-haskell/monad-logger-0.4:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/path-pieces-0.1.2:=[profile?] <dev-haskell/path-pieces-0.3:=[profile?]
+ >=dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/shakespeare-2.0:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?]
+ >=dev-haskell/wai-extra-3.0.7:=[profile?]
+ >=dev-haskell/wai-logger-0.2:=[profile?]
+ >=dev-haskell/warp-3.0.2:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit
+ dev-haskell/network
+ dev-haskell/streaming-commons )
+"