summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:46 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:22 +0100
commit7ad348958edf48ee20a4c86cfb256c237b4af722 (patch)
tree6a74b3906b6a06570f6d162958cb887d0c0178f4 /dev-haskell
parentdev-haskell/uuid-types: Hackage revision bump (diff)
downloadgentoo-7ad348958edf48ee20a4c86cfb256c237b4af722.tar.gz
gentoo-7ad348958edf48ee20a4c86cfb256c237b4af722.tar.bz2
gentoo-7ad348958edf48ee20a4c86cfb256c237b4af722.zip
dev-haskell/uuid: Hackage revision bump
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/uuid/Manifest1
-rw-r--r--dev-haskell/uuid/metadata.xml3
-rw-r--r--dev-haskell/uuid/uuid-1.3.15-r1.ebuild42
-rw-r--r--dev-haskell/uuid/uuid-1.3.15.ebuild36
4 files changed, 45 insertions, 37 deletions
diff --git a/dev-haskell/uuid/Manifest b/dev-haskell/uuid/Manifest
index 6f51a6b5747e..df4bff53385b 100644
--- a/dev-haskell/uuid/Manifest
+++ b/dev-haskell/uuid/Manifest
@@ -1 +1,2 @@
+DIST uuid-1.3.15-rev2.cabal 2642 BLAKE2B db44dabaa7962207d089fb79db6781e4387fb1958366e938125ec95d79125fc277fe1167a0aab2d133441c95a70953cee5ab30b4a1811bfd5c6733f178239ed5 SHA512 cb8a0aa11945375d175de2c48c710ef0f423d38fa4960ef91050e04038a402b38f532e25d5f56ecd715513dbb05da25922744ffde51edd8bb99b55985c9342be
DIST uuid-1.3.15.tar.gz 8815 BLAKE2B fec665690dc6fe05e9b7083700ca5ba2723d9bbd7cdc7f8770359d26b9b4b32572e15b686bc4589a3bed2cd25caa02cbea96270ea2e373941451aa6f315df401 SHA512 acb5c17b809bee5ce2f1591f3382a7c3a57e9d20a47d8f47be717b0e7fbfd803603810ebaaf88597bcf98dff698f4807dc7d8122a0d7d36785a47e0e065fb59e
diff --git a/dev-haskell/uuid/metadata.xml b/dev-haskell/uuid/metadata.xml
index 8bd9ed7a20bf..5626c2e65497 100644
--- a/dev-haskell/uuid/metadata.xml
+++ b/dev-haskell/uuid/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
- <remote-id type="github">aslatter/uuid</remote-id>
+ <remote-id type="hackage">uuid</remote-id>
+ <remote-id type="github">haskell-hvr/uuid</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/uuid/uuid-1.3.15-r1.ebuild b/dev-haskell/uuid/uuid-1.3.15-r1.ebuild
new file mode 100644
index 000000000000..679ee0de762c
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.15-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/haskell-hvr/uuid"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12
+ >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12
+ >=dev-haskell/entropy-0.3.7:=[profile?] <dev-haskell/entropy-0.5
+ =dev-haskell/network-info-0.2*:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3
+ =dev-haskell/uuid-types-1.0.5*:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ || (
+ ( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3 )
+ =dev-haskell/text-2.0*
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ =dev-haskell/tasty-hunit-0.10*
+ =dev-haskell/tasty-quickcheck-0.10*
+ )
+"
diff --git a/dev-haskell/uuid/uuid-1.3.15.ebuild b/dev-haskell/uuid/uuid-1.3.15.ebuild
deleted file mode 100644
index 86d31756c2da..000000000000
--- a/dev-haskell/uuid/uuid-1.3.15.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite has too new tasty
-inherit haskell-cabal
-
-DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
-HOMEPAGE="https://github.com/haskell-hvr/uuid"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RESTRICT=test
-
-RDEPEND=">=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12:=[profile?]
- >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
- >=dev-haskell/entropy-0.3.7:=[profile?] <dev-haskell/entropy-0.5:=[profile?]
- >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
- >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
- >=dev-haskell/uuid-types-1.0.5:=[profile?] <dev-haskell/uuid-types-1.0.6:=[profile?]
- >=dev-lang/ghc-8.4.3:=
- >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1"
-# test? ( >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
-# >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
-# >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
-# >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
-# "