summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:20 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:16 +0100
commit7655d915860c9375e96397c809e45329a470f518 (patch)
tree3972677fe8fb95e9105e84107aedfb8cdb7f2686 /dev-haskell
parentdev-haskell/timezone-olson: add 0.2.1 (diff)
downloadgentoo-7655d915860c9375e96397c809e45329a470f518.tar.gz
gentoo-7655d915860c9375e96397c809e45329a470f518.tar.bz2
gentoo-7655d915860c9375e96397c809e45329a470f518.zip
dev-haskell/timezone-series: add 0.1.13
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/timezone-series/Manifest2
-rw-r--r--dev-haskell/timezone-series/metadata.xml11
-rw-r--r--dev-haskell/timezone-series/timezone-series-0.1.13.ebuild24
3 files changed, 30 insertions, 7 deletions
diff --git a/dev-haskell/timezone-series/Manifest b/dev-haskell/timezone-series/Manifest
index b617a547f1f3..0c0476aca0e1 100644
--- a/dev-haskell/timezone-series/Manifest
+++ b/dev-haskell/timezone-series/Manifest
@@ -1 +1,3 @@
+DIST timezone-series-0.1.13-rev1.cabal 1528 BLAKE2B 75c04c5c149cd7fcbc4670ab1f2fadc4091661642c7a411688528da5059df2ef2f3b44450bcb5f3774c8c04bd0522ed37c1c49bff35b66a5ef00c59b8a206b13 SHA512 11a8bd7b3cdd06622118d78767e5df7d4645a201e8b2c0fa7a3d3923852bd1d26c79b685e4e2bf9eb3a2eeadb6b6acde0dc0c8d2124903b52a50a15b33573d7e
+DIST timezone-series-0.1.13.tar.gz 5682 BLAKE2B 284ba6c0c4b17bd2d2d6074afdfef6139b487ed2e9799a40c1f7389c30410f87f0d84f3dee163377ce378dedbb1a91f68416ed1830685e7854126927ba578d90 SHA512 7e98bf1030f9df88d031f8fe28e56f50bd8e5da7615165324b5132a77aecc70da5906e2068afa43a819d711725c4c6cae8f6d17e7803f50b31038eb1634d4992
DIST timezone-series-0.1.9.tar.gz 5812 BLAKE2B d45a62af6ac050406cded2740acb9988a25e38f80637e8dc8d7856786985ffe22a287873f878312faeddb524189a169af5ea6c1109613106dfc70cbba80b8b7a SHA512 9a716223270dfcb0ed39e2dcfb460e3540c0f2444f703c466cbd48ad5664e689aa3f6595f32e59b96fef7891aafabc03c9925367a26c2c043cb6adca2dad7a88
diff --git a/dev-haskell/timezone-series/metadata.xml b/dev-haskell/timezone-series/metadata.xml
index d179825cb7d9..d4b89ac92552 100644
--- a/dev-haskell/timezone-series/metadata.xml
+++ b/dev-haskell/timezone-series/metadata.xml
@@ -5,11 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package endows Data.Time, from the time
- package, with several data types and functions
- for enhanced processing of timezones. For one way
- to create timezone series, see the timezone-olson
- package.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">timezone-series</remote-id>
+ <remote-id type="github">ygale/timezone-series</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/timezone-series/timezone-series-0.1.13.ebuild b/dev-haskell/timezone-series/timezone-series-0.1.13.ebuild
new file mode 100644
index 000000000000..a4ddec0c2066
--- /dev/null
+++ b/dev-haskell/timezone-series/timezone-series-0.1.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Enhanced timezone handling for Data.Time"
+HOMEPAGE="https://projects.haskell.org/time-ng/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"