summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:27 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:17 +0100
commit711a9749346c63fa187b5bae3f504a0a6504249c (patch)
tree718a8bdfe4b60cd0f1c4f6a7896d3abf95c43dfc /dev-haskell
parentdev-haskell/trifecta: add 2.1.3 (diff)
downloadgentoo-711a9749346c63fa187b5bae3f504a0a6504249c.tar.gz
gentoo-711a9749346c63fa187b5bae3f504a0a6504249c.tar.bz2
gentoo-711a9749346c63fa187b5bae3f504a0a6504249c.zip
dev-haskell/typed-process: add 0.2.10.1-r1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/typed-process/Manifest1
-rw-r--r--dev-haskell/typed-process/files/typed-process-0.2.10.1-smp-flag.patch62
-rw-r--r--dev-haskell/typed-process/metadata.xml4
-rw-r--r--dev-haskell/typed-process/typed-process-0.2.10.1-r1.ebuild44
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-haskell/typed-process/Manifest b/dev-haskell/typed-process/Manifest
index cd4d0143b3a0..2a158b0c3a82 100644
--- a/dev-haskell/typed-process/Manifest
+++ b/dev-haskell/typed-process/Manifest
@@ -1 +1,2 @@
+DIST typed-process-0.2.10.1.tar.gz 18264 BLAKE2B eef9769f018bd8702656b6d151fa1148b1991ca9d877b507542327881576dd5297ebac0d8b86d9f305d734e3f07413a7a23f8160752b34d896e2386026347aad SHA512 07ab11cc1554aeaf8980df5fbe105de71282424365be9e26e94b7cbad344d3d0d9d54fc492615e32ec0e6d3064a72c7996be03e7fbb81136df366511d7bd606d
DIST typed-process-0.2.6.0.tar.gz 17363 BLAKE2B 033c1da191fcf10ca36b1215303793d26b3435e7241ee07e4c3389a9892be496779f70ae62b6bbad7f07704866473e16d4f15bfb6f22efa41243cba6ad72e941 SHA512 a40b8db4ef2179273943a3aab0200891bd3dffe584bcd51037ddf9cebae88d4d95292883a745a0c31900c7bf2eebe2c71175fbb86dc470b60660b443f8b1e3e0
diff --git a/dev-haskell/typed-process/files/typed-process-0.2.10.1-smp-flag.patch b/dev-haskell/typed-process/files/typed-process-0.2.10.1-smp-flag.patch
new file mode 100644
index 000000000000..fca0ea238d4c
--- /dev/null
+++ b/dev-haskell/typed-process/files/typed-process-0.2.10.1-smp-flag.patch
@@ -0,0 +1,62 @@
+From: hololeap <hololeap@protonmail.com>
+Signed-off-by: hololeap <hololeap@protonmail.com>
+Bug: https://github.com/fpco/typed-process/pull/60
+
+This flag will toggle the use of some ghc-options in the typed-process-test
+test suite. It is set to default: True.
+
+This is needed for tests to run on some GHC builds which do not support SMP.
+
+diff -urN typed-process-0.2.10.1/typed-process.cabal typed-process-0.2.10.1-r1/typed-process.cabal
+--- typed-process-0.2.10.1/typed-process.cabal 2022-10-28 09:12:23.834918081 -0600
++++ typed-process-0.2.10.1-r1/typed-process.cabal 2022-10-28 09:12:42.724917857 -0600
+@@ -1,6 +1,6 @@
+ cabal-version: 1.12
+
+--- This file has been generated from package.yaml by hpack version 0.34.4.
++-- This file has been generated from package.yaml by hpack version 0.35.0.
+ --
+ -- see: https://github.com/sol/hpack
+
+@@ -24,6 +24,11 @@
+ type: git
+ location: https://github.com/fpco/typed-process
+
++flag smp
++ description: Use flags that depend on GHC supporting a multicore runtime (tests only)
++ manual: True
++ default: True
++
+ library
+ exposed-modules:
+ System.Process.Typed
+@@ -40,9 +45,9 @@
+ , stm
+ , transformers
+ , unliftio-core
++ default-language: Haskell2010
+ if os(windows)
+ cpp-options: -DWINDOWS
+- default-language: Haskell2010
+
+ test-suite typed-process-test
+ type: exitcode-stdio-1.0
+@@ -52,7 +57,6 @@
+ Paths_typed_process
+ hs-source-dirs:
+ test
+- ghc-options: -threaded -rtsopts -with-rtsopts=-N
+ build-depends:
+ async >=2.0
+ , base >=4.12 && <5
+@@ -66,6 +70,10 @@
+ , typed-process
+ , unliftio-core
+ default-language: Haskell2010
++ if flag(smp)
++ ghc-options: -threaded -rtsopts -with-rtsopts=-N
++ else
++ ghc-options: -threaded
+
+ test-suite typed-process-test-single-threaded
+ type: exitcode-stdio-1.0
diff --git a/dev-haskell/typed-process/metadata.xml b/dev-haskell/typed-process/metadata.xml
index 937381521944..c387243a2d03 100644
--- a/dev-haskell/typed-process/metadata.xml
+++ b/dev-haskell/typed-process/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">typed-process</remote-id>
+ <remote-id type="github">fpco/typed-process</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/typed-process/typed-process-0.2.10.1-r1.ebuild b/dev-haskell/typed-process/typed-process-0.2.10.1-r1.ebuild
new file mode 100644
index 000000000000..3f70890a31fa
--- /dev/null
+++ b/dev-haskell/typed-process/typed-process-0.2.10.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit ghc-package haskell-cabal
+
+DESCRIPTION="Run external processes, with strong typing of streams"
+HOMEPAGE="https://github.com/fpco/typed-process"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.10.1-smp-flag.patch"
+)
+
+RDEPEND="
+ >=dev-haskell/async-2.0:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ >=dev-lang/ghc-8.6.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( dev-haskell/base64-bytestring
+ dev-haskell/hspec
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ if ghc-supports-smp; then
+ local smp_flag=smp
+ else
+ local smp_flag=-smp
+ fi
+
+ haskell-cabal_src_configure \
+ --flag="${smp_flag}"
+}