summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:02 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:27 +0100
commit6c55b70aef4203fdd9497e64db5ed98824771412 (patch)
tree94590174e0f2acf7a79f887bc17215fd23692806 /dev-haskell
parentdev-haskell/wl-pprint-annotated: Hackage revision bump (diff)
downloadgentoo-6c55b70aef4203fdd9497e64db5ed98824771412.tar.gz
gentoo-6c55b70aef4203fdd9497e64db5ed98824771412.tar.bz2
gentoo-6c55b70aef4203fdd9497e64db5ed98824771412.zip
dev-haskell/x509-store: add 1.6.9
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/x509-store/Manifest1
-rw-r--r--dev-haskell/x509-store/metadata.xml1
-rw-r--r--dev-haskell/x509-store/x509-store-1.6.9.ebuild29
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/x509-store/Manifest b/dev-haskell/x509-store/Manifest
index cdc76da92328..33e1adca7f37 100644
--- a/dev-haskell/x509-store/Manifest
+++ b/dev-haskell/x509-store/Manifest
@@ -1 +1,2 @@
DIST x509-store-1.6.7.tar.gz 12689 BLAKE2B 13e879b6a46e662de0660c5a2257881e50487d2667180030dca0dcf33a60718c75aa6413daa5b874622eaf9612e6cad7009ecd84d2d517bb5769beb4eafe4ec7 SHA512 7b0b792a988aed50995523c3f6a3bb0da08cb8963ad834afbeef8bc53e4bb3d7d11af757a999f7b5c81ef073bac10a4003fba7486abd9343a48770bfc954167e
+DIST x509-store-1.6.9.tar.gz 12734 BLAKE2B f7b7ca1dcba3f2a08cc4f887da074604ac855f0a381a5e87a9283d864e18e7c9e436def2dff58c55d73eaf9e19e4d15a3e5f4d3980585b1cfbe2a992b1a8d688 SHA512 10d0f4a4cb88852d8fd79676908e712ecc19a1b54cae9245f976eea1382abc03392e7fa593973180e6cfd9eb3c1de7133cf738a7c8b3a86d02278d2777d3af96
diff --git a/dev-haskell/x509-store/metadata.xml b/dev-haskell/x509-store/metadata.xml
index adbae2cc1fad..cfceea26acb5 100644
--- a/dev-haskell/x509-store/metadata.xml
+++ b/dev-haskell/x509-store/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
+ <remote-id type="hackage">x509-store</remote-id>
<remote-id type="github">vincenthz/hs-certificate</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/x509-store/x509-store-1.6.9.ebuild b/dev-haskell/x509-store/x509-store-1.6.9.ebuild
new file mode 100644
index 000000000000..a65b9e8098fb
--- /dev/null
+++ b/dev-haskell/x509-store/x509-store-1.6.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="X.509 collection accessing and storing methods"
+HOMEPAGE="https://github.com/vincenthz/hs-certificate"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.7.2:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit )
+"