summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:13 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:14 +0100
commit404904f7777b51b02261bc5aacc2e8799a97e995 (patch)
treec0841404a134a76e479b8f1c928ba294c2b576d2 /dev-haskell
parentdev-haskell/th-abstraction: add 0.4.5.0 (diff)
downloadgentoo-404904f7777b51b02261bc5aacc2e8799a97e995.tar.gz
gentoo-404904f7777b51b02261bc5aacc2e8799a97e995.tar.bz2
gentoo-404904f7777b51b02261bc5aacc2e8799a97e995.zip
dev-haskell/th-compat: add 0.1.4
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/th-compat/Manifest2
-rw-r--r--dev-haskell/th-compat/metadata.xml4
-rw-r--r--dev-haskell/th-compat/th-compat-0.1.4.ebuild29
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/th-compat/Manifest b/dev-haskell/th-compat/Manifest
index 6bf33d0d57c2..817ab6fe7663 100644
--- a/dev-haskell/th-compat/Manifest
+++ b/dev-haskell/th-compat/Manifest
@@ -1 +1,3 @@
DIST th-compat-0.1.3.tar.gz 13718 BLAKE2B ff925a0bd1f5a1de8008ce136cdd2c5e49aa6a58543df99d7179edaef65cea7d3ed3265ec5bdc31b5d5c01e65be25ddb1b393732d3b1f62a830a44f8c287554f SHA512 acb64eebf22093568fde29e7e5b78a8bce04d74b96a197a1c1f3383890b876c8d2e0a52206bbbc9708e3bf78a05f48e9bd3ea4929cbf6a7e712a4444917c1269
+DIST th-compat-0.1.4-rev2.cabal 3224 BLAKE2B 004c486fa4039444740af5ed883690ac754a5c9b06dbe54251d8e06990ca2e8e72184460d8a08cbf10140680c867e6b2a72a3bafa221616981e1671b85f7e9c3 SHA512 43540c5886eb07f32c8945d77c11af9132606b753640445ec264c1509339ebaaa958087ebfaa0b3dd1b46fca9f7b938b2846cd9df5ad1742e83dc4e377b469df
+DIST th-compat-0.1.4.tar.gz 14838 BLAKE2B 1c6a18b9199596db0d837804fa0c5d02ce86c8c2b26ccf357a2d68594ebe7ba49fa3162b34c8d54efa6e0e9b5c8d7c26a31c001e634b0a778fb4d7bb7b3342ef SHA512 2c9999343f33b2a74ca2439fdd111d038ae760c427fe1cb2c5778c4debdc49436c259f512a37e2bf4d765b83e925757bb23a48449ba5899586d409d5e15603ed
diff --git a/dev-haskell/th-compat/metadata.xml b/dev-haskell/th-compat/metadata.xml
index 937381521944..d21f5e1a8260 100644
--- a/dev-haskell/th-compat/metadata.xml
+++ b/dev-haskell/th-compat/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">th-compat</remote-id>
+ <remote-id type="github">haskell-compat/th-compat</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/th-compat/th-compat-0.1.4.ebuild b/dev-haskell/th-compat/th-compat-0.1.4.ebuild
new file mode 100644
index 000000000000..306e0b5a0863
--- /dev/null
+++ b/dev-haskell/th-compat/th-compat-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Backward- (and forward-)compatible Quote and Code types"
+HOMEPAGE="https://github.com/haskell-compat/th-compat"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/base-compat-0.6 <dev-haskell/base-compat-0.14
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ )
+"