summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:26 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:33 +0100
commit3d9e5f546f846c70df16917682a63baf81edd163 (patch)
tree6d12e6b4a323c22938d1f20cc7babcabb3bd173d /dev-haskell
parentdev-haskell/cairo: new package, add 0.13.10.0 (diff)
downloadgentoo-3d9e5f546f846c70df16917682a63baf81edd163.tar.gz
gentoo-3d9e5f546f846c70df16917682a63baf81edd163.tar.bz2
gentoo-3d9e5f546f846c70df16917682a63baf81edd163.zip
dev-haskell/glib: new package, add 0.13.10.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/glib/Manifest1
-rw-r--r--dev-haskell/glib/glib-0.13.10.0.ebuild38
-rw-r--r--dev-haskell/glib/metadata.xml16
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/glib/Manifest b/dev-haskell/glib/Manifest
new file mode 100644
index 000000000000..04856c88978b
--- /dev/null
+++ b/dev-haskell/glib/Manifest
@@ -0,0 +1 @@
+DIST glib-0.13.10.0.tar.gz 39410 BLAKE2B 4de054903034e366becd3735c8bf4a6900e39906d0aac526e7994cd0b8dae35765e88cbbc4062b138f88f33d37b96a637980042c310220c4c05ab27e0ed637d6 SHA512 59f85b442140c12338b9fecb0f51cee5aba64793f2c9baef9b50490024f58b27f6d1a525d03cf7bbd37eae49d9a0bbd75861dfc21c95a6e24de4cc991559e402
diff --git a/dev-haskell/glib/glib-0.13.10.0.ebuild b/dev-haskell/glib/glib-0.13.10.0.ebuild
new file mode 100644
index 000000000000..654997a0c298
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="https://projects.haskell.org/gtk2hs/"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+closure-signals"
+
+GHC_BOOTSTRAP_PACKAGES=(
+ gtk2hs-buildtools
+)
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0 <dev-haskell/cabal-3.11
+"
+BDEPEND=">=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure-signals closure_signals)
+}
diff --git a/dev-haskell/glib/metadata.xml b/dev-haskell/glib/metadata.xml
new file mode 100644
index 000000000000..53e5649323ab
--- /dev/null
+++ b/dev-haskell/glib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="closure-signals">Use the the GClosure-based signals
+&#9;&#9;implementation.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">glib</remote-id>
+ <remote-id type="github">gtk2hs/gtk2hs</remote-id>
+ </upstream>
+</pkgmetadata>