summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 12:50:26 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:58 +0100
commit45aacac538c659c9fd8b5cfa10d450404cda2b62 (patch)
tree435b610b1115f58ef8bed9fcee9d348c5c84763b /dev-haskell/skylighting-core
parentdev-haskell/pandoc-types: bump up to 1.20 (diff)
downloadgentoo-45aacac538c659c9fd8b5cfa10d450404cda2b62.tar.gz
gentoo-45aacac538c659c9fd8b5cfa10d450404cda2b62.tar.bz2
gentoo-45aacac538c659c9fd8b5cfa10d450404cda2b62.zip
dev-haskell/skylighting-core: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/skylighting-core')
-rw-r--r--dev-haskell/skylighting-core/Manifest1
-rw-r--r--dev-haskell/skylighting-core/metadata.xml25
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild53
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/skylighting-core/Manifest b/dev-haskell/skylighting-core/Manifest
new file mode 100644
index 000000000000..b0366c25c958
--- /dev/null
+++ b/dev-haskell/skylighting-core/Manifest
@@ -0,0 +1 @@
+DIST skylighting-core-0.8.5.tar.gz 675746 BLAKE2B 3a17423f5412228930df78e86b00b3d0339bced0a00e801a9986177f7099e9e5706b1858e3a4064db84eeec3b0fdde3f043b05b62de85d6a92d2d47a5cbb136d SHA512 ad411d7e0fd72adeb4cdbf6fc57d6191c51d9319b25c8d41ad35a66f885d518a842846cd7cf5ce35bdc31da74e0f9d97445f492628a4b5a2bceb85642aa23257
diff --git a/dev-haskell/skylighting-core/metadata.xml b/dev-haskell/skylighting-core/metadata.xml
new file mode 100644
index 000000000000..4dccbfb7b1c7
--- /dev/null
+++ b/dev-haskell/skylighting-core/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Build the skylighting executable.</flag>
+ </use>
+ <longdescription>
+ Skylighting is a syntax highlighting library.
+ It derives its tokenizers from XML syntax
+ definitions used by KDE&#39;s KSyntaxHighlighting
+ framework, so any syntax supported by that
+ framework can be added. An optional command-line
+ program is provided.
+ Skylighting is intended to be the successor to
+ highlighting-kate.
+ This package provides the core highlighting
+ functionality under a permissive license. It also
+ bundles XML parser definitions licensed under the
+ GPL.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild
new file mode 100644
index 000000000000..97378ef65296
--- /dev/null
+++ b/dev-haskell/skylighting-core/skylighting-core-0.8.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: +system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ >=dev-haskell/ansi-terminal-0.7:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/colour-2.0:=[profile?]
+ dev-haskell/hxt:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-pcre:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/pretty-show
+ dev-haskell/quickcheck
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}