summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/logict
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/logict')
-rw-r--r--dev-haskell/logict/Manifest2
-rw-r--r--dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch20
-rw-r--r--dev-haskell/logict/logict-0.6.0.1.ebuild27
-rw-r--r--dev-haskell/logict/logict-0.6.0.2.ebuild26
-rw-r--r--dev-haskell/logict/metadata.xml12
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-haskell/logict/Manifest b/dev-haskell/logict/Manifest
new file mode 100644
index 000000000000..bff5a6798529
--- /dev/null
+++ b/dev-haskell/logict/Manifest
@@ -0,0 +1,2 @@
+DIST logict-0.6.0.1.tar.gz 5288 SHA256 e2f6e0877ce9323d9401f55e68351e039135060e9d77c1b6b758177abacdf66b SHA512 ebed60ef3d977cdd6038482942447c66ceecd5c5e2ccbd801b510bf06c0dd7ef6f45b7af738ea3b149b58b4ad730ca286c31625eda4880dc71ba09b96e234774 WHIRLPOOL d54435f56fb8b78d7d327bab985f785e59a44b3ee8d1ffdabdbc6dc29435d68811471d74d6f5a8f7dcc7eca9b198e467f425e0d2392ffe0aa2c11e21093f7d75
+DIST logict-0.6.0.2.tar.gz 5370 SHA256 1182b68e8d00279460c7fb9b8284bf129805c07754c678b2a8de5a6d768e161e SHA512 dfb72d006d9b7a5f0d7447d956ea0c3d083e200a616efc4b34fafa0582c2dc7e9369156cf4f51a472b97f7afb6167030edeb84e77c7bc410bfe58a44f0ac4fc4 WHIRLPOOL 395780835fa55373db28b5d006ef260f4ff82f12d4aeeb1bd5bc83fe9a06f2613624a7ffc5e619420c2232b8abe6554b9488c73e71a6c5a016e2a89fc2b85eec
diff --git a/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch b/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch
new file mode 100644
index 000000000000..7e2449494e96
--- /dev/null
+++ b/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch
@@ -0,0 +1,20 @@
+--- logict-0.5.0-orig/Control/Monad/Logic.hs 2011-07-30 02:23:36.000000000 +1000
++++ logict-0.5.0/Control/Monad/Logic.hs 2012-01-06 20:53:00.424125711 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, MultiParamTypeClasses #-}
++{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, MultiParamTypeClasses, CPP #-}
+
+ -------------------------------------------------------------------------
+ -- |
+@@ -155,6 +155,11 @@
+ where
+ ssk a fk = return $ Just (a, (lift fk >>= reflect))
+
++#if !MIN_VERSION_mtl(2,0,0)
++instance F.Foldable Identity where
++ foldMap f (Identity x) = f x
++#endif
++
+ instance (Monad m, F.Foldable m) => F.Foldable (LogicT m) where
+ foldMap f m = F.fold $ unLogicT m (liftM . mappend . f) (return mempty)
+
diff --git a/dev-haskell/logict/logict-0.6.0.1.ebuild b/dev-haskell/logict/logict-0.6.0.1.ebuild
new file mode 100644
index 000000000000..02398340ab24
--- /dev/null
+++ b/dev-haskell/logict/logict-0.6.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A backtracking logic-programming monad"
+HOMEPAGE="http://code.haskell.org/~dolio/logict"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-0"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.0-ghc-6.12.patch")
diff --git a/dev-haskell/logict/logict-0.6.0.2.ebuild b/dev-haskell/logict/logict-0.6.0.2.ebuild
new file mode 100644
index 000000000000..80210f3b86a5
--- /dev/null
+++ b/dev-haskell/logict/logict-0.6.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A backtracking logic-programming monad"
+HOMEPAGE="http://code.haskell.org/~dolio/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+"
diff --git a/dev-haskell/logict/metadata.xml b/dev-haskell/logict/metadata.xml
new file mode 100644
index 000000000000..80f0869f09c7
--- /dev/null
+++ b/dev-haskell/logict/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A continuation-based, backtracking, logic programming monad.
+ An adaptation of the two-continuation implementation found
+ in the paper &quot;Backtracking, Interleaving, and Terminating
+ Monad Transformers&quot; available here:
+ &lt;http://okmij.org/ftp/papers/LogicT.pdf&gt;
+ </longdescription>
+</pkgmetadata>