summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2024-10-01 16:03:58 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-10-01 16:19:35 +0200
commit924beb27a022ec4d58ef3ed12fc6c3ec18153dc7 (patch)
treea5912fe13c9dc0d99dbf9142751232c0c54a814f /dev-db
parentnet-im/synapse: add 1.116.0 (diff)
downloadgentoo-924beb27a022ec4d58ef3ed12fc6c3ec18153dc7.tar.gz
gentoo-924beb27a022ec4d58ef3ed12fc6c3ec18153dc7.tar.bz2
gentoo-924beb27a022ec4d58ef3ed12fc6c3ec18153dc7.zip
dev-db/redict: add 7.3.1
Bug: https://bugs.gentoo.org/940609 Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev> Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redict/Manifest1
-rw-r--r--dev-db/redict/redict-7.3.1.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/dev-db/redict/Manifest b/dev-db/redict/Manifest
index a15faf344ca6..27adfdcf937e 100644
--- a/dev-db/redict/Manifest
+++ b/dev-db/redict/Manifest
@@ -1 +1,2 @@
DIST redict-7.3.0.tar.gz 3414514 BLAKE2B dd2ce2fdd8fbede33ddea9fee34e81535b0948a8963fb0d3391aac32ddf786e5cce996d1d405d81182ef6098ab8389b3c71b95ff9d8cbc68637746538e36999d SHA512 d33f4dfaf728f5a22abe7a6223f3192c39dc41a32e7bcb0f453caaa859f35b512534979c26ced9f4458c19611debd282f37955e930151c0f827035f349647226
+DIST redict-7.3.1.tar.gz 3414766 BLAKE2B ff4a4078683ec6e4f236e605e29711d1033c8632cd6c12035d7fdf1566d75d375daa61383fd8a6c098444e1cf382f5934f961e67a2041351fb4c9aaa6a7635c0 SHA512 79d174c0f58c73a52f3b0225280f69f92790f8d43cdf70a2353cefd06d73030ffb5e3eb30e06dcd9c47161f2d43a09cca6dc815e9dd83b620716c2ae3243d3bc
diff --git a/dev-db/redict/redict-7.3.1.ebuild b/dev-db/redict/redict-7.3.1.ebuild
new file mode 100644
index 000000000000..8218bbe76716
--- /dev/null
+++ b/dev-db/redict/redict-7.3.1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# N.B.: It is no clue in porting to Lua eclasses, as upstream have deviated
+# too far from vanilla Lua, adding their own APIs like lua_enablereadonlytable
+
+inherit edo multiprocessing systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="A persistent caching system, key-value, and data structures database"
+HOMEPAGE="https://redict.io"
+
+SRC_URI="https://codeberg.org/redict/redict/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+S=${WORKDIR}/${PN}
+
+LICENSE="BSD Boost-1.0 LGPL-3"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+jemalloc ssl systemd tcmalloc test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="?? ( jemalloc tcmalloc )"
+
+RDEPEND="
+ acct-group/redict
+ acct-user/redict
+ dev-libs/hiredict:0=[ssl?]
+ jemalloc? ( >=dev-libs/jemalloc-5.1:=[stats] )
+ ssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd:= )
+ tcmalloc? ( dev-util/google-perftools )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lang/tcl:0=
+ ssl? ( dev-tcltk/tls )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/redict-7.3.0-config.patch
+ "${FILESDIR}"/redict-sentinel-7.3.0-config.patch
+ "${FILESDIR}"/redict-7.3.0-system-jemalloc.patch
+ "${FILESDIR}"/redict-7.3.0-system-hiredict.patch
+)
+
+src_prepare() {
+ default
+
+ # Respect user CFLAGS in bundled lua
+ sed -i '/LUA_CFLAGS/s: -O2::g' deps/Makefile || die
+}
+
+_build() {
+ tc-export AR CC RANLIB
+ local myconf=(
+ AR="${AR}"
+ CC="${CC}"
+ RANLIB="${RANLIB}"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ V=1 # verbose
+ OPTIMIZATION=
+ DEBUG=
+ DEBUG_FLAGS=
+ BUILD_TLS=$(usex ssl)
+ USE_SYSTEMD=$(usex systemd)
+ USE_SYSTEM_HIREDICT=yes
+ )
+
+ if use jemalloc; then
+ myconf+=(
+ MALLOC=jemalloc
+ USE_SYSTEM_JEMALLOC=yes
+ )
+ elif use tcmalloc; then
+ myconf+=( MALLOC=tcmalloc )
+ else
+ myconf+=( MALLOC=libc )
+ fi
+
+ emake -C src "${myconf[@]}" "$@"
+}
+
+src_compile() {
+ _build
+}
+
+src_test() {
+ local runtestargs=(
+ --clients "$(makeopts_jobs)" # see bug #649868
+
+ --skiptest "Active defrag eval scripts" # see bug #851654
+ --skiptest "FUNCTION - redict version api" # test fails due to release mishap on 7.3.1, remove on bump
+ )
+
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "oom-score-adj related tests will be skipped." \
+ "They are known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ runtestargs+=(
+ # unit/oom-score-adj was introduced in version 6.2.0
+ --skipunit unit/oom-score-adj # see bug #756382
+
+ # Following test was added in version 7.0.0 to unit/introspection.
+ # It also tries to adjust OOM score.
+ --skiptest "CONFIG SET rollback on apply error"
+ )
+ fi
+
+ if use ssl; then
+ edo ./utils/gen-test-certs.sh
+ runtestargs+=( --tls )
+ fi
+
+ edo ./runtest "${runtestargs[@]}"
+}
+
+src_install() {
+ insinto /etc/redict
+ doins redict.conf sentinel.conf
+ use prefix || fowners -R redict:redict /etc/redict /etc/redict/{redict,sentinel}.conf
+
+ newconfd "${FILESDIR}/redict.confd" redict
+ newinitd "${FILESDIR}/redict.initd" redict
+
+ systemd_newunit "${FILESDIR}/redict.service" redict.service
+ newtmpfiles "${FILESDIR}/redict.tmpfiles" redict.conf
+
+ newconfd "${FILESDIR}/redict-sentinel.confd" redict-sentinel
+ newinitd "${FILESDIR}/redict-sentinel.initd" redict-sentinel
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/redict.logrotate" "${PN}"
+
+ _build DESTDIR="${ED}" PREFIX="/usr" install
+
+ if use prefix; then
+ diropts -m0750
+ else
+ diropts -m0750 -o redict -g redict
+ fi
+ keepdir /var/{log,lib}/redict
+}
+
+pkg_postinst() {
+ tmpfiles_process redict.conf
+
+ if has_version dev-db/redis && [[ -z "${REPLACING_VERSIONS}" ]]; then
+ ewarn "Redict uses different configuration files than redis:"
+ ewarn "/etc/redict/{redict,sentinel}.conf"
+ ewarn "Please apply your changes to the new configuration files."
+ fi
+}