summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2024-05-08 12:21:44 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2024-05-08 12:21:44 -0400
commit7db082572eed520969f76658b3ec02cbaee188de (patch)
tree6c41e567038c07f66626a9c062e97da7c3e56620 /dev-db
parentdev-qt/qtwebengine: "fix" build with clang-18 + -march=native (qt6) (diff)
downloadgentoo-7db082572eed520969f76658b3ec02cbaee188de.tar.gz
gentoo-7db082572eed520969f76658b3ec02cbaee188de.tar.bz2
gentoo-7db082572eed520969f76658b3ec02cbaee188de.zip
dev-db/pspg: add 5.8.5
Now with Bash completions and explicit remote-id. Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pspg/Manifest1
-rw-r--r--dev-db/pspg/metadata.xml3
-rw-r--r--dev-db/pspg/pspg-5.8.5.ebuild33
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/pspg/Manifest b/dev-db/pspg/Manifest
index 896cb738a04b..2d37fc3e2f6e 100644
--- a/dev-db/pspg/Manifest
+++ b/dev-db/pspg/Manifest
@@ -1,3 +1,4 @@
DIST pspg-5.5.4.tar.gz 2415002 BLAKE2B 1b7712318069c5fe69afe5e7477aa2a415d007a1f41af866726b11e65073c507ed12a51de14fc39ee06df9ccbe2763472332f55dda49167547e6ba590850bb5b SHA512 f13f4d7424d7b172a1fc5f963e7390a53f73f5c53ea4af7a9bed32dabc99f657e46cae550e8d5c7dd756b3496dd2ad665f3fd6551e54f9add1b3aef491709572
DIST pspg-5.5.8.tar.gz 2428371 BLAKE2B 09021f61c51698fd85ccf61c559014b6ffecad72079abf10c7dc50249bffbe34b86afa124a30a8d4f5c360af069ec623a4815288267a2ee225f7030de14b76d4 SHA512 f3fa9bc097ac43ab0113586b3474e9137c84b2ca844c45397a7ec185a01c66daa204f7bf739f7b65f1d741de02be8f7c1ba7df5abaa962008f33f6082c576b9f
DIST pspg-5.8.1.tar.gz 2442046 BLAKE2B 173b7250299927f140597d510e41aacad8be10b58e14094cbca2c2c3648925f71267a44728084ebf10cb832669c601ba121e529d7130b15cb2ab6accb3a9f77e SHA512 1ffcae86559f17e2cafba31a7bf9ba0170f4cdf8f2f5885a3650fea30463327e6a040e7746a8a074302fbb5080ce032a10775da503a5788a622203669609706f
+DIST pspg-5.8.5.tar.gz 2445232 BLAKE2B 90d6ca969bd365fea1801fb9125e4d3c5e92b916c7a13ae949a8170a7566d862d436c5d23358a6433ffa90bbf2551013b2f12a6c204614e0974c1fe6698c580e SHA512 f33be2e0ddd8f56054c82f4f3a8ea531faef2f9ca21a706f894f5419e8122d291a9174495d68dc8637728cc57fe764e63c34b843e8ed8a3b3ff7546a6c904e7e
diff --git a/dev-db/pspg/metadata.xml b/dev-db/pspg/metadata.xml
index 334189f9edab..b852c5503b93 100644
--- a/dev-db/pspg/metadata.xml
+++ b/dev-db/pspg/metadata.xml
@@ -12,4 +12,7 @@
supports searching, selecting rows, columns, or block and export
selected area to clipboard.
</longdescription>
+ <upstream>
+ <remote-id type="github">okbob/pspg</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-db/pspg/pspg-5.8.5.ebuild b/dev-db/pspg/pspg-5.8.5.ebuild
new file mode 100644
index 000000000000..30c83cc68ff9
--- /dev/null
+++ b/dev-db/pspg/pspg-5.8.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A better pager for CLI database clients and can be used in place of psql"
+HOMEPAGE="https://github.com/okbob/pspg"
+SRC_URI="https://github.com/okbob/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres"
+RESTRICT="test"
+
+RDEPEND="
+sys-libs/ncurses:=
+sys-libs/readline:=
+postgres? ( dev-db/postgresql:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with postgres postgresql)
+}
+
+src_install() {
+ default
+
+ newbashcomp bash-completion.sh ${PN}
+}