summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-01-22 12:22:31 -0500
committerBrian Evans <grknight@gentoo.org>2019-01-22 12:22:31 -0500
commit38d1c0af45cb88e995c75f3c7695e5f5cdbc73e1 (patch)
tree3b5da165f6b85886fc9f2b940e0521a5e3833a8d /dev-db/mycli/mycli-1.19.0.ebuild
parentx11-libs/libdrm: Version bump to 2.4.97 (diff)
downloadgentoo-38d1c0af45cb88e995c75f3c7695e5f5cdbc73e1.tar.gz
gentoo-38d1c0af45cb88e995c75f3c7695e5f5cdbc73e1.tar.bz2
gentoo-38d1c0af45cb88e995c75f3c7695e5f5cdbc73e1.zip
dev-db/mycli: Version bump for 1.19.0; Update 9999 requirements
Package-Manager: Portage-2.3.57, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-db/mycli/mycli-1.19.0.ebuild')
-rw-r--r--dev-db/mycli/mycli-1.19.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/mycli/mycli-1.19.0.ebuild b/dev-db/mycli/mycli-1.19.0.ebuild
new file mode 100644
index 000000000000..957f70361a50
--- /dev/null
+++ b/dev-db/mycli/mycli-1.19.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
+
+HOMEPAGE="https://www.mycli.net"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssh test"
+RDEPEND="
+ >=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}]
+ <dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
+ ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] ${RDEPEND} )"
+
+python_test() {
+ pytest --capture=sys \
+ --showlocals \
+ --doctest-modules \
+ --doctest-ignore-import-errors \
+ --ignore=setup.py \
+ --ignore=mycli/magic.py \
+ --ignore=mycli/packages/parseutils.py \
+ --ignore=test/features
+}