summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-11 23:40:59 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-12 02:24:36 -0600
commit70e6e303938221b98d4ce91eac0c33c7b56b2e88 (patch)
treef93c2428791c5f310abcda091aa250a8f4661d24 /app-vim/vimagit/vimagit-1.7.3.ebuild
parentdev-lang/ruby: 2.4.5-r1 for OpenSSL 1.1 "disable-deprecated" (diff)
downloadgentoo-70e6e303938221b98d4ce91eac0c33c7b56b2e88.tar.gz
gentoo-70e6e303938221b98d4ce91eac0c33c7b56b2e88.tar.bz2
gentoo-70e6e303938221b98d4ce91eac0c33c7b56b2e88.zip
app-vim/vimagit: version bump to 1.7.3
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/vimagit/vimagit-1.7.3.ebuild')
-rw-r--r--app-vim/vimagit/vimagit-1.7.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimagit/vimagit-1.7.3.ebuild b/app-vim/vimagit/vimagit-1.7.3.ebuild
new file mode 100644
index 000000000000..2fa87c6aceb4
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}