summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-07-02 23:52:56 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-07-02 23:53:19 +0200
commit7768bf09cf044c36623435166cbce2d1b7897f3a (patch)
tree54f77e9c6216b3d454a0b961584de325f47e0ea1 /app-vim/iris/iris-1.0.0.ebuild
parentapp-office/calligra: Drop 3.2.0 (diff)
downloadgentoo-7768bf09cf044c36623435166cbce2d1b7897f3a.tar.gz
gentoo-7768bf09cf044c36623435166cbce2d1b7897f3a.tar.bz2
gentoo-7768bf09cf044c36623435166cbce2d1b7897f3a.zip
app-vim/iris: new ebuild.
iris an IMAP mail client for vim. Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim/iris/iris-1.0.0.ebuild')
-rw-r--r--app-vim/iris/iris-1.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/iris/iris-1.0.0.ebuild b/app-vim/iris/iris-1.0.0.ebuild
new file mode 100644
index 000000000000..8e10bcffdb96
--- /dev/null
+++ b/app-vim/iris/iris-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit vim-plugin python-r1
+
+MY_PN="iris.vim"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: mail client for vim"
+HOMEPAGE="https://github.com/soywod/iris.vim"
+SRC_URI="https://github.com/soywod/iris.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/imapclient
+ ${PYTHON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ mv api.py iris-api || die
+ mv idle.py iris-idle || die
+ sed -e 's#api\.py#iris-api#g;' -i autoload/iris/api.vim || die
+ sed -e 's#idle\.py#iris-idle#g;' -i autoload/iris/idle.vim || die
+ python_foreach_impl python_doscript iris-api
+ python_foreach_impl python_doscript iris-idle
+
+ vim-plugin_src_install
+}