summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 16:41:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:36 +0200
commit1e87651d252c0e84379b0a1e1750a2048b614976 (patch)
treebe410b2db2f7c0e2baaf3f0760a6cbad12dfbe93 /app-vim/eruby-syntax
parentapp-vim/errsign: EAPI8 bump (diff)
downloadgentoo-1e87651d252c0e84379b0a1e1750a2048b614976.tar.gz
gentoo-1e87651d252c0e84379b0a1e1750a2048b614976.tar.bz2
gentoo-1e87651d252c0e84379b0a1e1750a2048b614976.zip
app-vim/eruby-syntax: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/eruby-syntax')
-rw-r--r--app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild b/app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild
new file mode 100644
index 000000000000..2bf72a0fb743
--- /dev/null
+++ b/app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for eruby"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=403"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT="This plugin provides syntax highlighting for eruby"
+
+src_prepare() {
+ default
+ sed -i -e 's#hi link#hi def link#' syntax/eruby.vim || die "sed failed"
+}