summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 12:41:46 +0000
committerSam James <sam@gentoo.org>2021-01-12 12:51:07 +0000
commitddb6374f505ef384039ad5c44a2223ff31507207 (patch)
tree51940104c899a368c3ad7952ad49990757911ed5 /app-text
parentmedia-sound/lilypond: bump to 2.22.0 (diff)
downloadgentoo-ddb6374f505ef384039ad5c44a2223ff31507207.tar.gz
gentoo-ddb6374f505ef384039ad5c44a2223ff31507207.tar.bz2
gentoo-ddb6374f505ef384039ad5c44a2223ff31507207.zip
app-text/dvisvgm: bump to 2.11
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-2.11.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 69148bdcf829..1ef89304f5f3 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -1,4 +1,5 @@
DIST dvisvgm-2.1.3.tar.gz 2802278 BLAKE2B 36e523d4b82a71f26ebc50428c56863a3729d1cf79c63660a5a3cecdd7c55c27e7ad811121e8a2ccdaa37f1ec2fb345d1d5d4f7b59011be7877500df5dba1f48 SHA512 dfd6e94b28dcdf2d1be236f3f29eaf4e3e5b7bb34544cdd55ae09de612b02561dd782b693a9a94eea07420c795d31ef210eba34cb663d7de98f438c089369ff2
DIST dvisvgm-2.10.1.tar.gz 3110061 BLAKE2B 3f3bb50baa587c1d20061d235885b4c921efbd3400aa7e4d2df872e37e0ef57d57ae4713fedfd0587d7fcffe7e0286ca55e319e6e82b3b72b49c5df5fa08f633 SHA512 8faa68b13a0e351ba54b5c9acb1dbda6e081eddd167b2cc599208cc2e7967c116c3d105d29df224165daff88f81acb3135d936ec9b2da4dce2c82c197f6a4e78
+DIST dvisvgm-2.11.tar.gz 3111889 BLAKE2B 7944b62bee48173f1ed0e2de5ff0c8090322da925abdd4a57611ccb5c055ba602a76ab4e3dbddb83d73ac19a23ce4b657d96a3830f76eb8939f3e3a9c0890cd1 SHA512 bbefff027f710a0370d179e42f1775cb37765836969fcf9e27e5e05d46565e6db74414440823068b04dbef0dac768b70b2573359fe729c12b27f6d678f41d55f
DIST dvisvgm-2.6.1.tar.gz 2911596 BLAKE2B 8dfe85140db4b462c1721a8bad322d52535a0fced4bb8c374c342bd4ca8fe5cf6dfa5751a8a8070b9ce622ab7bb7df14985802c596fdc387f90febc80151fbd6 SHA512 791183f92ec4733574614fd5b8b4247a7b766b62b1aa7b1444d508d0358178b1447b24fb51d09948d99552c2cb7ed3a0f9bce0416b66de8a4835f85476bbdb25
DIST dvisvgm-2.7.tar.gz 3037242 BLAKE2B f93bcc4220adf4b2c0d7e06deb11416f22c623f07c96ca9aa9093054e18ec72f8da1d93aa4ee467f82f9478bb0c1b8acebbb56de020f47563056dd0dbea5936e SHA512 b706085015d1ab4c9b88997cf6c1c93f6c0ee60c9d1429d3fba7bed7b5acb3392958f64b4207ae27e6eb52abb19ff9640e2b7459e4b19ae21986b82d4b65b182
diff --git a/app-text/dvisvgm/dvisvgm-2.11.ebuild b/app-text/dvisvgm/dvisvgm-2.11.ebuild
new file mode 100644
index 000000000000..af466d3dc91b
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-2.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="https://dvisvgm.de/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+BDEPEND="
+ app-text/xmlto
+ app-text/asciidoc
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ >=app-arch/brotli-1.0.5
+ app-text/ghostscript-gpl
+ dev-libs/kpathsea:=
+ >=dev-libs/xxhash-0.6.5
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ dev-libs/kpathsea
+ sys-libs/zlib
+ virtual/tex-base
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myargs=(
+ --without-ttfautohint
+ )
+
+ econf "${myargs[@]}"
+}