summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-07-29 18:19:55 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-07-29 18:19:55 +0700
commitb1bb334292bbd0a56d7ada5b2de56098b7f920f1 (patch)
tree0856466b27caccad1aa0118c24ad23fb0aea3fb7 /app-text
parentsci-geosciences/gpxsee: bump to 13.23 (diff)
downloadgentoo-b1bb334292bbd0a56d7ada5b2de56098b7f920f1.tar.gz
gentoo-b1bb334292bbd0a56d7ada5b2de56098b7f920f1.tar.bz2
gentoo-b1bb334292bbd0a56d7ada5b2de56098b7f920f1.zip
app-text/master-pdf-editor: bump to 5.9.85
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.9.85.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
index 5e96a1124f34..9ecd2d73d5d4 100644
--- a/app-text/master-pdf-editor/Manifest
+++ b/app-text/master-pdf-editor/Manifest
@@ -1,2 +1,3 @@
DIST master-pdf-editor-5.9.82-qt5.x86_64.tar.gz 80442378 BLAKE2B bd6357097451595388be3471b291ceb23b6815ed9ce68956223860c089265ae3693cee1c90f94e567e26b3a0f11b8dee8c2cf40e0184141e2539b44303d6a4c4 SHA512 d4613b5d5353e3bd39bcf953adff2d086e20de6a627e5e6dade62cb7887254b949659174ee3ba86ac525d2373fcedbdb286dc83ffca910c577cbf9ccc14ced39
DIST master-pdf-editor-5.9.84.x86_64-qt5_include.tar.gz 82574581 BLAKE2B 53f21f11043f97c177010712b375101e29e2078a434e5791691e566b30d6a7b910ba735039b1ffd05c284e21fa478a3c1977b9bef6fe28c563bf5616f6379433 SHA512 9eca9f6504a919c1d8c00f51795c603b955cd69b02b05ad72943eb4561226ec5045f61f28f39e5a97b9c46ec9a6f49f64e92d2f6ee76b69ca09d84135b67f020
+DIST master-pdf-editor-5.9.85-qt5.x86_64-qt_include.tar.gz 61727253 BLAKE2B baf438bcbd250aec1df3a471ae146c5410a5511473cc6e2d0d07e1d9752fbdde6caf3ddd2eab19f0afff3f9d5cc083ffea9f8464c743dc7b603bec191703f1b0 SHA512 a66f905f7afa7ec40d076b1544d5cf18bfd547212123c297e79bf2403b69ec91c39f3ef6fb298b53bc2df4d580db5025c6af64e3031fe286fb9b9d59f2483139
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.9.85.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.9.85.ebuild
new file mode 100644
index 000000000000..5eeaa3fa535e
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.9.85.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}-qt5.x86_64-qt_include.tar.gz"
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ sys-libs/glibc
+ dev-libs/pkcs11-helper
+ >=dev-qt/qtcore-5.12.9:5
+ >=dev-qt/qtgui-5.12.9:5
+ >=dev-qt/qtnetwork-5.12.9:5
+ >=dev-qt/qtprintsupport-5.12.9:5
+ >=dev-qt/qtsvg-5.12.9:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+ >=media-gfx/sane-backends-1.0
+"
+
+QA_PREBUILT="opt/${PN}/masterpdfeditor5"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts help iconengines imageformats lang platforms platformthemes stamps templates masterpdfeditor5.png
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5 masterpdfeditor5.sh
+ exeinto /opt/bin
+ doexe "${FILESDIR}"/mpe5
+
+ make_desktop_entry "mpe5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}