summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-09-19 12:51:33 +0100
committerMarek Szuba <marecki@gentoo.org>2023-09-19 13:52:21 +0100
commit43c74666b813e1747cc7cbddeabd867823e50d2c (patch)
tree562afaf063c475d220748acd6e9b03a88476d413 /app-text
parentdev-db/postgresql: Drop threads use flag (diff)
downloadgentoo-43c74666b813e1747cc7cbddeabd867823e50d2c.tar.gz
gentoo-43c74666b813e1747cc7cbddeabd867823e50d2c.tar.bz2
gentoo-43c74666b813e1747cc7cbddeabd867823e50d2c.zip
app-text/xchm: add 1.36
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xchm/Manifest1
-rw-r--r--app-text/xchm/xchm-1.36.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/xchm/Manifest b/app-text/xchm/Manifest
index a0185f8462e0..710bcb101d07 100644
--- a/app-text/xchm/Manifest
+++ b/app-text/xchm/Manifest
@@ -1 +1,2 @@
DIST xchm-1.35.tar.gz 884353 BLAKE2B ce77f43e462e803e6ceed1cd91e56650cc054245daa5bb18c215eb649cb8ba6a39591265d6c753670a852ff7ac2fe84aa0b7c915b9ade8631de686884d808f1c SHA512 53a334b460c2de51b1f5a6afbca888e376430ab2fb48f2d60c71d34886b19ca5982cf3a4f23c3cb7456781c3b658affa5a64da3ade961accf258096b5fa6df3d
+DIST xchm-1.36.tar.gz 882212 BLAKE2B 8f11457664748fa3effb23102b23ee59c3184a408f6defa3bc7d7bf90c97357a74d33f5da6b7098011a1c23a9f3dd9a523076e367aa9547c9d72f25296b6c787 SHA512 0b7397cd188e47cf9e39c21081428356d858d7ff7e82dd928ef728f32d962ecd485ef2b44ff0c063bde67a605d7a4610f1f5100d1c30d691e6546434c615da65
diff --git a/app-text/xchm/xchm-1.36.ebuild b/app-text/xchm/xchm-1.36.ebuild
new file mode 100644
index 000000000000..ed93e6bfae5e
--- /dev/null
+++ b/app-text/xchm/xchm-1.36.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+
+inherit desktop wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="https://github.com/rzvncj/xCHM/"
+SRC_URI="https://github.com/rzvncj/xCHM/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_configure() {
+ setup-wxwidgets
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}