summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-22 11:02:29 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-22 11:05:16 -0400
commit1a787194357b749a50ab7c60eed5efbd874ba86b (patch)
tree5e6ea143a4ad004ffcdcbe3ebd88822e3c660d67 /app-text
parentmozcoreconf-v5.eclass: change 'eval unset' to 'unset' (diff)
downloadgentoo-1a787194357b749a50ab7c60eed5efbd874ba86b.tar.gz
gentoo-1a787194357b749a50ab7c60eed5efbd874ba86b.tar.bz2
gentoo-1a787194357b749a50ab7c60eed5efbd874ba86b.zip
app-text/csvfix: update to EAPI 6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/csvfix/csvfix-1.6.ebuild20
-rw-r--r--app-text/csvfix/metadata.xml1
2 files changed, 13 insertions, 8 deletions
diff --git a/app-text/csvfix/csvfix-1.6.ebuild b/app-text/csvfix/csvfix-1.6.ebuild
index 50b599f4355b..e79e239ef7de 100644
--- a/app-text/csvfix/csvfix-1.6.ebuild
+++ b/app-text/csvfix/csvfix-1.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils toolchain-funcs versionator vcs-snapshot
+inherit toolchain-funcs versionator vcs-snapshot
MY_PV="$(delete_all_version_separators)"
DESCRIPTION="A stream editor for manipulating CSV files"
@@ -20,10 +20,13 @@ RDEPEND="dev-libs/expat"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${PN}-1.10a-tests.patch
+)
+src_prepare() {
+ default
edos2unix $(find csvfix/tests -type f)
}
@@ -39,5 +42,8 @@ src_test() {
src_install() {
dobin csvfix/bin/csvfix
- use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}/*
+ if use doc; then
+ docinto html
+ dodoc -r "${WORKDIR}"/${PN}${MY_PV}/*
+ fi
}
diff --git a/app-text/csvfix/metadata.xml b/app-text/csvfix/metadata.xml
index 85df0b57fb4f..8aaa5d2f6787 100644
--- a/app-text/csvfix/metadata.xml
+++ b/app-text/csvfix/metadata.xml
@@ -6,7 +6,6 @@
<name>Tim Harder</name>
</maintainer>
<upstream>
- <remote-id type="google-code">csvfix</remote-id>
<remote-id type="bitbucket">neilb/csvfix</remote-id>
</upstream>
</pkgmetadata>