summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 18:53:55 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 20:16:24 +0100
commit976fc8d4267ba9aef486d87c0086468bc9f2f076 (patch)
tree3f4a6b666414c8bbc1b6079856e8f6f5b735e806 /app-text/zathura-ps
parentapp-text/zathura-pdf-poppler: Port to git-r3 (diff)
downloadgentoo-976fc8d4267ba9aef486d87c0086468bc9f2f076.tar.gz
gentoo-976fc8d4267ba9aef486d87c0086468bc9f2f076.tar.bz2
gentoo-976fc8d4267ba9aef486d87c0086468bc9f2f076.zip
app-text/zathura-ps: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/zathura-ps')
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.2.ebuild24
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.4.ebuild20
-rw-r--r--app-text/zathura-ps/zathura-ps-9999.ebuild24
3 files changed, 32 insertions, 36 deletions
diff --git a/app-text/zathura-ps/zathura-ps-0.2.2.ebuild b/app-text/zathura-ps/zathura-ps-0.2.2.ebuild
index 63e6d80aa0f9..222e0fbcc204 100644
--- a/app-text/zathura-ps/zathura-ps-0.2.2.ebuild
+++ b/app-text/zathura-ps/zathura-ps-0.2.2.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="PostScript plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/libspectre-0.2.6:=
@@ -30,7 +28,7 @@ RDEPEND=">=app-text/libspectre-0.2.6:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
diff --git a/app-text/zathura-ps/zathura-ps-0.2.4.ebuild b/app-text/zathura-ps/zathura-ps-0.2.4.ebuild
index ade2d3e11a04..222e0fbcc204 100644
--- a/app-text/zathura-ps/zathura-ps-0.2.4.ebuild
+++ b/app-text/zathura-ps/zathura-ps-0.2.4.ebuild
@@ -4,21 +4,21 @@
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="PostScript plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
-fi
IUSE=""
RDEPEND=">=app-text/libspectre-0.2.6:=
@@ -28,7 +28,7 @@ RDEPEND=">=app-text/libspectre-0.2.6:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
diff --git a/app-text/zathura-ps/zathura-ps-9999.ebuild b/app-text/zathura-ps/zathura-ps-9999.ebuild
index f2c470b53ec1..222eb1f4a012 100644
--- a/app-text/zathura-ps/zathura-ps-9999.ebuild
+++ b/app-text/zathura-ps/zathura-ps-9999.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="PostScript plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/libspectre-0.2.6:=
@@ -30,7 +28,7 @@ RDEPEND=">=app-text/libspectre-0.2.6:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"