summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/yagf/yagf-0.9.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/yagf/yagf-0.9.2.ebuild')
-rw-r--r--app-text/yagf/yagf-0.9.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/yagf/yagf-0.9.2.ebuild b/app-text/yagf/yagf-0.9.2.ebuild
new file mode 100644
index 000000000000..272c3dfeb9b3
--- /dev/null
+++ b/app-text/yagf/yagf-0.9.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+CMAKE_IN_SOURCE_BUILD=1
+PLOCALES="de lt pl ru uk"
+inherit cmake-utils l10n
+
+DESCRIPTION="Graphical front-end for cuneiform and tesseract OCR tools"
+HOMEPAGE="http://symmetrica.net/cuneiform-linux/yagf-en.html"
+SRC_URI="http://symmetrica.net/cuneiform-linux/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scanner cuneiform +tesseract pdf"
+
+REQUIRED_USE="|| ( cuneiform tesseract )"
+
+DEPEND=">=dev-qt/qtgui-4.7:4
+ app-text/aspell"
+RDEPEND="${DEPEND}
+ cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )
+ scanner? ( media-gfx/xsane )
+ pdf? ( || ( app-text/poppler[utils] app-text/ghostscript-gpl ) )"
+
+DOCS=( AUTHORS ChangeLog DESCRIPTION README )
+
+src_prepare() {
+ l10n_find_plocales_changes "src/translations" "${PN}_" '.ts'
+
+ epatch_user
+}
+
+src_install() {
+ remove_translation() {
+ rm "${ED}/usr/share/yagf/translations/${PN}_${1}.qm" || die "remove '${PN}_${1}.qm' file failed"
+ }
+ cmake-utils_src_install
+ l10n_for_each_disabled_locale_do remove_translation
+}