summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Santos <joaompssantos@gmail.com>2021-08-05 22:26:50 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-08-06 11:49:58 +0200
commitdbb46ce06f804600103ace4f6960d1217b0abbb2 (patch)
treed63917a1dfdc2ac628534343e73f4bb87069e798 /app-text/master-pdf-editor
parentapp-text/master-pdf-editor: drop 5.7.40 (diff)
downloadgentoo-dbb46ce06f804600103ace4f6960d1217b0abbb2.tar.gz
gentoo-dbb46ce06f804600103ace4f6960d1217b0abbb2.tar.bz2
gentoo-dbb46ce06f804600103ace4f6960d1217b0abbb2.zip
app-text/master-pdf-editor: bump 5.7.90
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: João Santos <joaompssantos@gmail.com> Closes: https://bugs.gentoo.org/800839 Closes: https://github.com/gentoo/gentoo/pull/21895 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/master-pdf-editor')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.7.90.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
new file mode 100644
index 000000000000..8a28e07ea954
--- /dev/null
+++ b/app-text/master-pdf-editor/Manifest
@@ -0,0 +1 @@
+DIST master-pdf-editor-5.7.90-qt5.x86_64.tar.gz 15962243 BLAKE2B 4331a5d17ed9a0ff7a70c353907a4c0d5e99db447760f6103d412eabe0064b1e4ac59ca85bb0cab2bffc5867c8ccde96f68e7ceee227b7b319d93b70482f233d SHA512 823c7212cd3d469bb972e7da66e6eada31149c0bab2a6c577e537ca203862d0fe862e8c9b0cbb479eca0557da4b69a91a88ae0c9215d3b5f105288a9c6c1f2bf
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.7.90.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.7.90.ebuild
new file mode 100644
index 000000000000..1300656eb4a5
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.7.90.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}-qt5.x86_64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ dev-libs/nss
+ >=dev-qt/qtcore-5.12.9:5
+ >=dev-qt/qtgui-5.12.9:5
+ >=dev-qt/qtnetwork-5.12.9:5
+ >=dev-qt/qtprintsupport-5.12.9:5
+ >=dev-qt/qtsvg-5.12.9:5
+ >=media-gfx/sane-backends-1.0
+"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}