summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-27 23:07:52 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-27 23:09:51 +0000
commit9c6fba50bf7e0629c343cece1faf1fb5ae8c2697 (patch)
treed502bac3f522f160c0d855743ee732d32891fd88 /app-text/languagetool
parentdev-java/jython: Bump guava SLOT, drop readline, EAPI bump (diff)
downloadgentoo-9c6fba50bf7e0629c343cece1faf1fb5ae8c2697.tar.gz
gentoo-9c6fba50bf7e0629c343cece1faf1fb5ae8c2697.tar.bz2
gentoo-9c6fba50bf7e0629c343cece1faf1fb5ae8c2697.zip
app-text/languagetool: Bump guava SLOT, use Gentoo Java scripts
guava:20 is needed so that Java 7 can be dropped from Gentoo. Using our Java scripts makes the ebuild cleaner, avoids symlinks, and ensures that the correct JVM is chosen at runtime. There are still many external libraries being bundled and we don't have the time to package them all right now but I have bumped jackson and friends to a newer version than is bundled here so that can be used and I've also introduced commons-collections:4. I noticed that jna:0 was used before, which is version 3, but it's actually version 4 that's bundled so I've amended that dependency. This was given the +1 by Radhermit. Package-Manager: portage-2.3.2
Diffstat (limited to 'app-text/languagetool')
-rw-r--r--app-text/languagetool/languagetool-3.5-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-text/languagetool/languagetool-3.5-r1.ebuild b/app-text/languagetool/languagetool-3.5-r1.ebuild
new file mode 100644
index 000000000000..cd931e1e1004
--- /dev/null
+++ b/app-text/languagetool/languagetool-3.5-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit java-pkg-2
+
+MY_PN=LanguageTool
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A proof-reading tool for many languages"
+HOMEPAGE="http://www.languagetool.org/"
+SRC_URI="http://www.languagetool.org/download/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CP_DEPEND="
+ dev-java/commons-cli:1
+ dev-java/commons-collections:4
+ dev-java/commons-io:1
+ dev-java/commons-lang:2.1
+ dev-java/commons-logging:0
+ dev-java/guava:20
+ dev-java/hamcrest-core:1.3
+ dev-java/jackson:2
+ dev-java/jackson-databind:2
+ dev-java/jcommander:0
+ dev-java/jna:4
+ dev-java/slf4j-api:0
+ dev-java/slf4j-nop:0
+"
+
+RDEPEND=">=virtual/jre-1.8
+ ${CP_DEPEND}"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ rm -v libs/{commons,hamcrest,guava,jackson,jcommander,jna,junit,slf4j}*.jar || die
+
+ # Loads of bundled stuff :(
+ #java-pkg-2_src_prepare
+}
+
+src_compile() { :; }
+
+src_install() {
+ java-pkg_dojar *.jar libs/*.jar
+
+ local DIR=/usr/share/${PN}/lib/language-modules
+ java-pkg_addcp "${EPREFIX}${DIR}"
+ insinto ${DIR}
+ doins -r org META-INF
+
+ java-pkg_dolauncher ${PN} --main org.${PN}.commandline.Main
+ java-pkg_dolauncher ${PN}-gui --main org.${PN}.gui.Main
+
+ dodoc CHANGES.md README.md
+
+ unset MY_DEPEND
+ java-pkg_gen-cp MY_DEPEND
+ java-pkg_register-dependency "${MY_DEPEND}"
+}