summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-02-16 17:56:48 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-02-16 17:57:17 +0700
commitf14b74a12991c6b170625c818c67a24ab4201c3b (patch)
treed65d66d46349f8ab2cd8734f5fb17f1bc1fc3492 /app-text/foliate
parentapp-misc/empty: version bump (diff)
downloadgentoo-f14b74a12991c6b170625c818c67a24ab4201c3b.tar.gz
gentoo-f14b74a12991c6b170625c818c67a24ab4201c3b.tar.bz2
gentoo-f14b74a12991c6b170625c818c67a24ab4201c3b.zip
app-text/foliate: add python3_11
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/foliate')
-rw-r--r--app-text/foliate/foliate-2.6.4-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/foliate/foliate-2.6.4-r2.ebuild b/app-text/foliate/foliate-2.6.4-r2.ebuild
new file mode 100644
index 000000000000..55777f866399
--- /dev/null
+++ b/app-text/foliate/foliate-2.6.4-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="cs de es eu fr id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit meson python-any-r1 plocale xdg gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ sys-devel/gettext
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+src_prepare() {
+ default
+ python_fix_shebang build-aux/meson
+ xdg_environment_reset
+
+ plocale_find_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_po
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}