summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2020-06-15 09:00:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-20 22:30:50 +0200
commit9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5 (patch)
tree67c3aa0c56dd98ff01e366e17f148dcb9ebde1fc /app-shells/zsh-completions/zsh-completions-0.32.0.ebuild
parentnet-misc/rclone-1.52.1 version bump (diff)
downloadgentoo-9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5.tar.gz
gentoo-9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5.tar.bz2
gentoo-9ac5ef4e490dd0d9a29f686fa65abd5328f93ec5.zip
app-shells/zsh-completions: Bump to 0.32.0
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/16249 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-shells/zsh-completions/zsh-completions-0.32.0.ebuild')
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.32.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/zsh-completions-0.32.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.32.0.ebuild
new file mode 100644
index 000000000000..bac7cbeb28ce
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.32.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}