summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/synce-sync-engine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/synce-sync-engine')
-rw-r--r--app-pda/synce-sync-engine/Manifest1
-rw-r--r--app-pda/synce-sync-engine/metadata.xml11
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild73
3 files changed, 85 insertions, 0 deletions
diff --git a/app-pda/synce-sync-engine/Manifest b/app-pda/synce-sync-engine/Manifest
new file mode 100644
index 000000000000..2de5293449d9
--- /dev/null
+++ b/app-pda/synce-sync-engine/Manifest
@@ -0,0 +1 @@
+DIST synce-sync-engine-0.15.1.tar.gz 173406 SHA256 bdee6ba59d3106768dbe61f4f353ae2b59cbf1112cd274128f52a86d180370c4 SHA512 ef4855c24e8bff7da0e3eeccfc495e98ccd3817f20683f9648b6370cef05a22fa49ce19514efea9936d416120a7881ef930b433d7800b2f19c11ceb585aff827 WHIRLPOOL 534acbcf3abd29235d1073c96157832631ca1a408b8ed3fa4571daa09e7ee74c4a2ac73d5262cdae6bf353a563ea7be9dac5985d41fa2b00694576cc24751fd3
diff --git a/app-pda/synce-sync-engine/metadata.xml b/app-pda/synce-sync-engine/metadata.xml
new file mode 100644
index 000000000000..8b3d48c77d27
--- /dev/null
+++ b/app-pda/synce-sync-engine/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <use>
+ <flag name="opensync">Enable OpenSync (<pkg>app-pda/libopensync</pkg>) python plug-in</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">synce</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
new file mode 100644
index 000000000000..9bc4c188ccd3
--- /dev/null
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils multilib
+
+DESCRIPTION="A synchronization engine for SynCE"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opensync"
+
+RDEPEND="app-pda/synce-core[python]
+ >=dev-libs/librra-0.16[python]
+ >=dev-libs/librtfcomp-1.2[python]
+ dev-libs/libxml2[python]
+ dev-libs/libxslt[python]
+ dev-python/dbus-python
+ dev-python/pygobject:2
+ opensync? ( || (
+ >=app-pda/libopensync-0.39[python]
+ ( =app-pda/libopensync-0.22*[python] app-pda/libopensync-plugin-python )
+ ) )"
+DEPEND=${RDEPEND}
+
+PYTHON_MODNAME=SyncEngine
+
+src_prepare() {
+ sed -i -e 's:share/doc/sync-engine:foobar:' setup.py || die
+
+ distutils_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/dbus-1/services
+ doins config/org.synce.SyncEngine.service || die
+
+ insinto /etc
+ doins config/syncengine.conf.xml || die
+
+ distutils_src_install
+
+ ### opensync plug-in BEGIN
+ find "${ED}" -type d -name plugins -exec rm -rf {} +
+
+ if use opensync; then
+ local plug=plugins/synce-opensync-plugin-
+
+ if has_version ">=app-pda/libopensync-0.39"; then
+ insinto /usr/$(get_libdir)/libopensync1/python-plugins
+ newins ${plug}3x.py synce-plugin.py || die
+ else
+ # See OPENSYNC_PYTHONPLG_DIR variable in libopensync-python-plugin-0.22
+ # to verify path for python plugins.
+ insinto /usr/$(get_libdir)/opensync/python-plugins
+ newins ${plug}2x.py synce-plugin.py || die
+ fi
+
+ dodoc ${plug}3x.README || die
+ fi
+ ### opensync plug-in END
+
+ rm -rf "${ED}"/usr/foobar
+}