summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-03-07 15:55:19 +0100
committerPacho Ramos <pacho@gentoo.org>2024-03-07 15:57:11 +0100
commit40e7133682e86311ad4140771770137b82a3ba00 (patch)
tree7ddf10fd398c81a0c3e7f0cd787c3672e87da512 /app-office
parentprofiles/base: mask >=kde-misc/kdeconnect-24.02.0[bluetooth] (diff)
downloadgentoo-40e7133682e86311ad4140771770137b82a3ba00.tar.gz
gentoo-40e7133682e86311ad4140771770137b82a3ba00.tar.bz2
gentoo-40e7133682e86311ad4140771770137b82a3ba00.zip
app-office/impressive: add 0.13.2
Closes: https://bugs.gentoo.org/920263 Closes: https://bugs.gentoo.org/912960 Thanks-to: Wicher Minnaard Thanks-to: Micha Glave Thanks-to: Andrés Becerra Sandoval Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/impressive/Manifest1
-rw-r--r--app-office/impressive/impressive-0.13.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index b13f47f7d0fe..3602b0f0c96d 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1 +1,2 @@
DIST Impressive-0.13.1.tar.gz 215989 BLAKE2B 6591e5fa2c34e7e6f2283b9b6f8cce7485fc8932eea571af96c895bbe23202af195eec0318272667d5656f3aed7a88a21a20397224c7c0cc7c9252364d832371 SHA512 f6221337f9dd79f552fb083e1ea7484aeadec1f8d8e05b4e1b7f6a94037b5026022819b346968dea67dbdb1b646d0571a7aeef26f15c25bee88c5b9c2791cf2b
+DIST Impressive-0.13.2.tar.gz 294531 BLAKE2B 76b50cd1cb1366c9fed7e6f7a16142248f99e232b96b7d7372af181f3ef215aff6f3453d8fd16c2ab6fa0e7217ec831daf3ffafcb8e46ff285dc0b9d86b77839 SHA512 0b24ef39cba25d8813fd3f95f220c466defa50c3ba4a63d2f37b284de2826c2110225fe2016f58c401d1ca239d672ba28ba65069523ab57b1b5711a4222cff92
diff --git a/app-office/impressive/impressive-0.13.2.ebuild b/app-office/impressive/impressive-0.13.2.ebuild
new file mode 100644
index 000000000000..7816aedb6b69
--- /dev/null
+++ b/app-office/impressive/impressive-0.13.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit optfeature python-r1
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN^}/${PV/_/-}/${PN^}-${PV/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mupdf
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ || (
+ media-fonts/dejavu
+ media-fonts/corefonts
+ )
+"
+
+DOCS=( changelog.txt demo.pdf )
+HTML_DOCS=( impressive.html )
+
+S="${WORKDIR}/${PN^}-${PV/_/-}"
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}