summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-09-29 10:54:35 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-09-29 10:54:35 +0300
commitc1a8ae7989fa7cd806355e7be306e09622074d2c (patch)
treee59119e76649fe74857b462eac946cc0a3310f15 /app-misc
parentapp-misc/fastfetch: drop 2.24.0, 2.25.0 (diff)
downloadgentoo-c1a8ae7989fa7cd806355e7be306e09622074d2c.tar.gz
gentoo-c1a8ae7989fa7cd806355e7be306e09622074d2c.tar.bz2
gentoo-c1a8ae7989fa7cd806355e7be306e09622074d2c.zip
app-misc/fastfetch: sync live ebuilds
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fastfetch/fastfetch-0.1.9999.ebuild5
-rw-r--r--app-misc/fastfetch/fastfetch-0.2.9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/app-misc/fastfetch/fastfetch-0.1.9999.ebuild b/app-misc/fastfetch/fastfetch-0.1.9999.ebuild
index 4fb2091c80a6..6186f29ea3dc 100644
--- a/app-misc/fastfetch/fastfetch-0.1.9999.ebuild
+++ b/app-misc/fastfetch/fastfetch-0.1.9999.ebuild
@@ -20,19 +20,21 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="X chafa dbus ddcutil drm gnome imagemagick opencl opengl osmesa pulseaudio sqlite test vulkan wayland xcb xfce xrandr"
+IUSE="X chafa dbus ddcutil drm elf gnome imagemagick opencl opengl osmesa pulseaudio sqlite test vulkan wayland xcb xfce xrandr"
RESTRICT="!test? ( test )"
# note - qa-vdb will always report errors because fastfetch loads the libs dynamically
# make sure to crank yyjson minimum version to match bundled version
RDEPEND="
>=dev-libs/yyjson-0.10.0
+ sys-apps/hwdata
sys-libs/zlib
X? ( x11-libs/libX11 )
chafa? ( media-gfx/chafa )
dbus? ( sys-apps/dbus )
ddcutil? ( app-misc/ddcutil:= )
drm? ( x11-libs/libdrm )
+ elf? ( virtual/libelf:= )
gnome? (
dev-libs/glib
gnome-base/dconf
@@ -83,6 +85,7 @@ src_configure() {
-DENABLE_DCONF=$(usex gnome)
-DENABLE_DDCUTIL=$(usex ddcutil)
-DENABLE_DRM=$(usex drm)
+ -DENABLE_ELF=$(usex elf)
-DENABLE_EGL=$(usex opengl)
-DENABLE_GIO=$(usex gnome)
-DENABLE_GLX=$(usex opengl)
diff --git a/app-misc/fastfetch/fastfetch-0.2.9999.ebuild b/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
index 4fb2091c80a6..6186f29ea3dc 100644
--- a/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
+++ b/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
@@ -20,19 +20,21 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="X chafa dbus ddcutil drm gnome imagemagick opencl opengl osmesa pulseaudio sqlite test vulkan wayland xcb xfce xrandr"
+IUSE="X chafa dbus ddcutil drm elf gnome imagemagick opencl opengl osmesa pulseaudio sqlite test vulkan wayland xcb xfce xrandr"
RESTRICT="!test? ( test )"
# note - qa-vdb will always report errors because fastfetch loads the libs dynamically
# make sure to crank yyjson minimum version to match bundled version
RDEPEND="
>=dev-libs/yyjson-0.10.0
+ sys-apps/hwdata
sys-libs/zlib
X? ( x11-libs/libX11 )
chafa? ( media-gfx/chafa )
dbus? ( sys-apps/dbus )
ddcutil? ( app-misc/ddcutil:= )
drm? ( x11-libs/libdrm )
+ elf? ( virtual/libelf:= )
gnome? (
dev-libs/glib
gnome-base/dconf
@@ -83,6 +85,7 @@ src_configure() {
-DENABLE_DCONF=$(usex gnome)
-DENABLE_DDCUTIL=$(usex ddcutil)
-DENABLE_DRM=$(usex drm)
+ -DENABLE_ELF=$(usex elf)
-DENABLE_EGL=$(usex opengl)
-DENABLE_GIO=$(usex gnome)
-DENABLE_GLX=$(usex opengl)