summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-10 13:30:26 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-10 13:47:13 -0400
commitd88ae4bd318ce5b69b1896ffbde7164d69585828 (patch)
tree177f10ddb99111f690e9818b8a3f535f0b49f7b0 /app-misc/wayland-utils
parentx11-base/xwayland: Version bump to 23.1.2 (diff)
downloadgentoo-d88ae4bd318ce5b69b1896ffbde7164d69585828.tar.gz
gentoo-d88ae4bd318ce5b69b1896ffbde7164d69585828.tar.bz2
gentoo-d88ae4bd318ce5b69b1896ffbde7164d69585828.zip
app-misc/wayland-utils: Version bump to 1.2.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/wayland-utils')
-rw-r--r--app-misc/wayland-utils/Manifest1
-rw-r--r--app-misc/wayland-utils/wayland-utils-1.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/wayland-utils/Manifest b/app-misc/wayland-utils/Manifest
index c9fb0b78c348..f82d41ca3018 100644
--- a/app-misc/wayland-utils/Manifest
+++ b/app-misc/wayland-utils/Manifest
@@ -1 +1,2 @@
DIST wayland-utils-1.1.0.tar.bz2 14071 BLAKE2B b2726205c8d123a4543aa316928fe2909917f70bbde4318376581c1ec97f658f0d5743a7df091799ef2adce4c962e83aefdc805e25cf1af5429520eddff2918c SHA512 5cd842c286c1960c1f604287826625c23c87306e9e31daba23a65402d4ae0abd0cec4a701c8fb65af2aea6adbcb018660e646939062c51628a65dde41ebd64bf
+DIST wayland-utils-1.2.0.tar.bz2 15169 BLAKE2B 65f1486e4fcaa86e8b113f3342a23fc03b0025932284f2e9471321efcef59db258bc8cf730b3e0daa656c275fe92ef35f1d7fedfb21a7e32fd1b375c6a26a41d SHA512 fcf7c85273b099aa51462302dec89514707bbe162b791db1ba07b6807de5651cee57cf8a6b7fd63365739c967bfb544d89684e9d399677d563d056b0147baa7e
diff --git a/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild b/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
new file mode 100644
index 000000000000..8ed4e3533def
--- /dev/null
+++ b/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Display information about supported Wayland protocols and current compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wayland/wayland-utils"
+SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/wayland-1.20.0
+ >=x11-libs/libdrm-2.4.109
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local emesonargs=(
+ -Ddrm=enabled
+ )
+ meson_src_configure
+}