summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2022-02-26 21:51:28 +0100
committerPatrice Clement <monsieurp@gentoo.org>2022-02-26 22:03:03 +0100
commit61bfb24291f7d052e4234bc3169e59037a5b1f8a (patch)
tree273d7ddbb9c11b0775928a38708584369080e028 /app-misc/todo
parentapp-misc/todo: update EAPI 7 -> 8 (diff)
downloadgentoo-61bfb24291f7d052e4234bc3169e59037a5b1f8a.tar.gz
gentoo-61bfb24291f7d052e4234bc3169e59037a5b1f8a.tar.bz2
gentoo-61bfb24291f7d052e4234bc3169e59037a5b1f8a.zip
app-misc/todo: drop 2.11.0, 2.12.0-r1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc/todo')
-rw-r--r--app-misc/todo/Manifest1
-rw-r--r--app-misc/todo/todo-2.11.0.ebuild64
-rw-r--r--app-misc/todo/todo-2.12.0-r1.ebuild64
3 files changed, 0 insertions, 129 deletions
diff --git a/app-misc/todo/Manifest b/app-misc/todo/Manifest
index aa534da6d988..d4cfd196b9ca 100644
--- a/app-misc/todo/Manifest
+++ b/app-misc/todo/Manifest
@@ -1,2 +1 @@
-DIST todo-2.11.0.tar.gz 712455 BLAKE2B f9d0fa53712a49c2f6ee94c02a62c16b8184734f7bb0c9354db9d640e2f619c75e3b3468065cb51204c7872f1f155bda51b9e3387f62f0f478f80f6a99f199b4 SHA512 5500ed1aa10eceaaa3e5116605eed4f4228337fdc0f2ceaa5b889753a60576918c0953adbfbf80c40008d6dfdf854e8a538103bfed4d1015aa1c5a9876c2e47c
DIST todo-2.12.0.tar.gz 716524 BLAKE2B 168951c50670228ba2e1438ec04f5907181073668f1e260874e48959f2e37d11ee7ba4f2b0e5e5c55c9375a31921eca258f720afe98d2a4841529ef6acbb1510 SHA512 3b30d5e395f878811831f57e8e1a040c990e1f042f57050b6381d83ffc8b92b1ce20bfd3c5aa8b5e028b4810a5b289599603b2e16efff8badac559d200ed79f5
diff --git a/app-misc/todo/todo-2.11.0.ebuild b/app-misc/todo/todo-2.11.0.ebuild
deleted file mode 100644
index c3a527e1a45c..000000000000
--- a/app-misc/todo/todo-2.11.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1
-
-DESCRIPTION="A CLI-based TODO list manager"
-HOMEPAGE="http://todotxt.org"
-SRC_URI="https://github.com/todotxt/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-shells/bash"
-
-PATCHES=( "${FILESDIR}/${P}-fix-bash-completion.patch" )
-
-DOCS=( README.md CONTRIBUTING.md LICENSE todo.cfg )
-
-S="${WORKDIR}/${PN}.txt-cli-${PV}"
-
-src_prepare() {
- default
-
- # fix version string
- sed -i -e "s/@DEV_VERSION@/${PV}/" todo.sh || die
-
- # TODO_DIR variable is bogus
- sed -i -e '/export TODO_DIR/d' todo.cfg || die
- sed -i -e '4i export TODO_DIR="$HOME/.todo"' todo.cfg || die
-}
-
-src_install() {
- dobin "${PN}.sh"
- dosym "${PN}.sh" "/usr/bin/${PN}cli"
- dosym "${PN}.sh" "/usr/bin/${PN}txt"
- newbashcomp "${PN}_completion" "${PN}.sh"
- bashcomp_alias "${PN}.sh" "${PN}cli" "${PN}txt"
- einstalldocs
-}
-
-pkg_postinst() {
- einfo
- einfo 'Before starting todo, make sure to create'
- einfo 'a .todo directory in your home directory:'
- einfo ' $ mkdir -p $HOME/.todo'
- einfo
- einfo 'and make sure to copy the default todo'
- einfo 'configuration file in the same location:'
- einfo " $ bzcat /usr/share/doc/${PF}/todo.cfg.bz2 > \$HOME/.todo/config"
- einfo
- einfo 'Alternatively, you can use XDG directories instead:'
- einfo ' $ mkdir -p $HOME/.local/share/todo'
- einfo ' $ mkdir -p $HOME/.config/todo'
- einfo " $ bzcat /usr/share/doc/${PF}/todo.cfg.bz2 > \$HOME/.config/todo/config"
- einfo
- einfo 'You can then edit this file as you see fit.'
- einfo 'Enjoy!'
- einfo
-}
diff --git a/app-misc/todo/todo-2.12.0-r1.ebuild b/app-misc/todo/todo-2.12.0-r1.ebuild
deleted file mode 100644
index 547d0e721b41..000000000000
--- a/app-misc/todo/todo-2.12.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1
-
-DESCRIPTION="A CLI-based TODO list manager"
-HOMEPAGE="http://todotxt.org"
-SRC_URI="https://github.com/todotxt/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-shells/bash"
-
-DOCS=( README.md LICENSE todo.cfg )
-
-S="${WORKDIR}/${PN}.txt-cli-${PV}"
-
-src_prepare() {
- default
-
- # fix version string
- sed -i -e "s/@DEV_VERSION@/${PV}/" todo.sh || die
-
- # TODO_DIR variable is bogus
- sed -i -e '/export TODO_DIR/d' todo.cfg || die
- sed -i -e '4i export TODO_DIR="$HOME/.todo"' todo.cfg || die
-}
-
-src_install() {
- dobin "${PN}.sh"
- newbashcomp "${PN}_completion" "${PN}.sh"
- einstalldocs
-}
-
-pkg_postinst() {
- einfo
- einfo 'Before starting todo, make sure to create'
- einfo 'a .todo directory in your home directory:'
- einfo ' $ mkdir -p $HOME/.todo'
- einfo
- einfo 'and make sure to copy the default todo'
- einfo 'configuration file in the same location:'
- einfo " $ bzcat /usr/share/doc/${PF}/todo.cfg.bz2 > \$HOME/.todo/config"
- einfo
- einfo 'Alternatively, you can use XDG directories instead:'
- einfo ' $ mkdir -p $HOME/.local/share/todo'
- einfo ' $ mkdir -p $HOME/.config/todo'
- einfo " $ bzcat /usr/share/doc/${PF}/todo.cfg.bz2 > \$HOME/.config/todo/config"
- einfo
- einfo 'You can then edit this file as you see fit.'
- einfo 'Enjoy!'
- einfo
- ewarn 'The Gentoo-specific todocli and todotxt aliases have been removed.'
- ewarn 'If you still need them, add the following lines to your ~/.bashrc:'
- ewarn
- ewarn 'alias todocli=todo.sh'
- ewarn 'complete -F _todo todocli'
-}