summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-03-06 11:47:27 -0600
committerBen Kohler <bkohler@gentoo.org>2024-03-06 11:53:59 -0600
commit71dc5ba0496485db973ce2938f1a2fa61b7947e9 (patch)
treefb6ade68047f160cd22af52e0ae6bbb760b37d77 /app-misc/lfm
parentprofiles: Mask app-portage/g-sorcery, app-portage/gs-elpa for removal (diff)
downloadgentoo-71dc5ba0496485db973ce2938f1a2fa61b7947e9.tar.gz
gentoo-71dc5ba0496485db973ce2938f1a2fa61b7947e9.tar.bz2
gentoo-71dc5ba0496485db973ce2938f1a2fa61b7947e9.zip
app-misc/lfm: use PEP517 build, update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/909883 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-misc/lfm')
-rw-r--r--app-misc/lfm/files/lfm-3.1-dont-error-on-wheel.patch14
-rw-r--r--app-misc/lfm/lfm-3.1-r1.ebuild29
2 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/lfm/files/lfm-3.1-dont-error-on-wheel.patch b/app-misc/lfm/files/lfm-3.1-dont-error-on-wheel.patch
new file mode 100644
index 000000000000..d74014fb05ff
--- /dev/null
+++ b/app-misc/lfm/files/lfm-3.1-dont-error-on-wheel.patch
@@ -0,0 +1,14 @@
+diff -ur lfm-3.1/setup.py lfm-3.1.new/setup.py
+--- lfm-3.1/setup.py 2024-03-06 11:44:37.646520051 -0600
++++ lfm-3.1.new/setup.py 2024-03-06 11:45:18.058725112 -0600
+@@ -45,10 +45,6 @@
+ print('ERROR: Python 3.4 or higher is required to run lfm.')
+ exit(-1)
+
+-# to avoid bug in pip 7.x. See https://bitbucket.org/pypa/wheel/issues/92
+-if 'bdist_wheel' in argv:
+- raise RuntimeError("This setup.py does not support wheels")
+-
+ import shutil
+ try:
+ try:
diff --git a/app-misc/lfm/lfm-3.1-r1.ebuild b/app-misc/lfm/lfm-3.1-r1.ebuild
new file mode 100644
index 000000000000..c6f5c61a6916
--- /dev/null
+++ b/app-misc/lfm/lfm-3.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Last File Manager is a powerful file manager for the console"
+HOMEPAGE="https://inigo.katxi.org/devel/lfm/"
+SRC_URI="https://inigo.katxi.org/devel/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/lfm-3.1-dont-error-on-wheel.patch )
+
+src_prepare() {
+ default
+ sed -e '/data_files/d' -i setup.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman ${PN}.1
+}