summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-06-13 19:10:36 -0700
committerZac Medico <zmedico@gentoo.org>2021-06-13 19:31:30 -0700
commite93d1fee89b2276e74ab81d966651833a4a875e3 (patch)
tree46ca5bd029a7a0d7bc0ac8089687ae357124e3ae /app-misc/jpipe/jpipe-0.0.1.ebuild
parentx11-misc/xscreensaver: Drop unused patch (diff)
downloadgentoo-e93d1fee89b2276e74ab81d966651833a4a875e3.tar.gz
gentoo-e93d1fee89b2276e74ab81d966651833a4a875e3.tar.bz2
gentoo-e93d1fee89b2276e74ab81d966651833a4a875e3.zip
app-misc/jpipe: Initial import
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-misc/jpipe/jpipe-0.0.1.ebuild')
-rw-r--r--app-misc/jpipe/jpipe-0.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/jpipe/jpipe-0.0.1.ebuild b/app-misc/jpipe/jpipe-0.0.1.ebuild
new file mode 100644
index 000000000000..0ac556bbf2b2
--- /dev/null
+++ b/app-misc/jpipe/jpipe-0.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python implementation of the jp CLI for JMESPath"
+HOMEPAGE="https://github.com/pipebus/jpipe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="jp-symlink test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ jp-symlink? ( !app-misc/jp )
+ dev-python/jmespath[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${PYTHON}" test/test_jpipe.py || die "tests failed for ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ use jp-symlink && dosym jpipe /usr/bin/jp
+}