summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-10-10 01:10:03 +0800
committerYixun Lan <dlan@gentoo.org>2024-10-11 08:06:30 +0800
commite23eccebb7bd44aab90e88234f995ab72f148c4c (patch)
tree63a72701ae614426092f1a50ce8023570a86207b /app-i18n
parentnet-im/telegram-desktop: add 5.6.1, drop 5.6.0 (diff)
downloadgentoo-e23eccebb7bd44aab90e88234f995ab72f148c4c.tar.gz
gentoo-e23eccebb7bd44aab90e88234f995ab72f148c4c.tar.bz2
gentoo-e23eccebb7bd44aab90e88234f995ab72f148c4c.zip
app-i18n/fcitx: add 5.1.11
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx/Manifest1
-rw-r--r--app-i18n/fcitx/fcitx-5.1.11.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/app-i18n/fcitx/Manifest b/app-i18n/fcitx/Manifest
index 7a939a33b1f3..88729b66a7c6 100644
--- a/app-i18n/fcitx/Manifest
+++ b/app-i18n/fcitx/Manifest
@@ -1,5 +1,6 @@
DIST fcitx-4.2.9.8_dict.tar.xz 8737888 BLAKE2B 2de3ccbf1b37a9bcf1a3cb257d7837669e946765722c3d6f442ad071d7d81a6e8178e47051fc3aa53b9b4771d3aca602c2e22fa7a3d117a9e1f2779497e02c52 SHA512 50a954c3178f53fd2d441cdaf81fb44a7fe8dfb263fa6d8dd4ee4884fc7ae8321880c726c9366d11e2a4ac8da2233268d06e5d0800d4527ba0bdb1a1430248ed
DIST fcitx-5.1.10.tar.zst 8309913 BLAKE2B a63f5c747dd1d7a519873f00f234ae43d1ab5458e57b809f01e2b6cefc3e3921ecd7fff27cf4b21d59842f11e8d397760d90cf6572b42f65d226b21acc18fefc SHA512 196bc26f7dd50596da90e6b4b0a8b4886b57ec928c182427fb8763507f1f4cb39a252bfddcbd6eccaa0cc920070b7b9fda03f18fd444f84154ddd925678ad7d4
+DIST fcitx-5.1.11.tar.zst 8310353 BLAKE2B b38daa03c40b19454cf8b82dc6c9d799730fb614bb606d86f0dfbadb6dd88f3a382f4c2b2a8f820bf4b01e27e27be82ed2624fb3f0a70843af5f72924e62e58b SHA512 d2fee4b931175d67ed29058af5dc644c6918829ca336e88566781ffaf5ccbe942281e9a41459b5ad8ad37756bed24b999127f8b17d8925bb923a9eb10d1081fb
DIST fcitx-data-en_dict-20121020.tar.gz 630491 BLAKE2B 2df897b1c9fb3a2ce186ee590e5f3ccbc7930f047218bf0fefa317f74b3287fc0be9c393d3310fe07208379118ec4c46608a1c703ef37b3aee65b2d790cb7f0d SHA512 8418bd02492bfd786c0fab93be4400ef027ec8e9fac02220cc1f653f5eb67f54573a6a84a15baba19bb34ab892745c87df16499d6304ea75009131e2ab3b97f2
DIST fcitx-data-pinyin.tar.gz 1608886 BLAKE2B 3b7e72559bb838b4f2245e6faf2d627df17e9383ef8fe382e10333c1a95d79409ec042caa7d77c9bcd956b1c5d5456dab9d82208cd89d90e2be759c76f56f3d1 SHA512 1ee19eed3ee58be6cd6562ec363fe3bf630fff5e8820b3bfdd6d4618fceb082695e888dec5366a3685d58706f720e19319d891c223227237aed12674ea982131
DIST fcitx-data-py_stroke-20121124.tar.gz 445601 BLAKE2B 43b29b30da11b18196918e4df847406871eff75595b62608ad86b0ef6de83ec5e1b722645cabb809281075b393b5970e4d9580594caa73060c866c2d3cd988e7 SHA512 d80ff9a3549e07c7a6935e686785f9a076c58f1a782a832ae28ee65e2a213d67f089f450ce09bed87ec2a141c32b9c1fcb83c221ddcab436858fa9009f161fb3
diff --git a/app-i18n/fcitx/fcitx-5.1.11.ebuild b/app-i18n/fcitx/fcitx-5.1.11.ebuild
new file mode 100644
index 000000000000..5d1c1f236db9
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-5.1.11.ebuild
@@ -0,0 +1,123 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Fcitx 5 is a generic input method framework"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5/fcitx5-${PV}_dict.tar.zst -> ${P}.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="LGPL-2+ Unicode-DFS-2016"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+autostart doc +emoji +enchant +keyboard presage +server systemd test wayland +X"
+REQUIRED_USE="
+ || ( wayland X )
+ X? ( keyboard )
+ wayland? ( keyboard )
+"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !app-i18n/fcitx:4
+ dev-libs/libfmt
+ sys-devel/gettext
+ virtual/libintl
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ doc? (
+ app-text/doxygen
+ dev-texlive/texlive-fontutils
+ )
+ emoji? ( sys-libs/zlib )
+ enchant? ( app-text/enchant:2 )
+ keyboard? (
+ app-text/iso-codes
+ dev-libs/expat
+ dev-libs/json-c:=
+ x11-misc/xkeyboard-config
+ x11-libs/libxkbcommon[X?,wayland?]
+ )
+ systemd? (
+ sys-apps/systemd
+ )
+ !systemd? (
+ dev-libs/libuv
+ sys-apps/dbus
+ )
+ wayland? (
+ dev-libs/glib:2
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+ X? (
+ dev-libs/glib:2
+ >=x11-libs/xcb-imdkit-1.0.3:5
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/xcb-util
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ kde-frameworks/extra-cmake-modules:0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DBUS=on
+ -DENABLE_XDGAUTOSTART=$(usex autostart)
+ -DENABLE_SERVER=$(usex server)
+ -DENABLE_KEYBOARD=$(usex keyboard)
+ -DENABLE_TEST=$(usex test)
+ -DENABLE_ENCHANT=$(usex enchant)
+ -DENABLE_EMOJI=$(usex emoji)
+ -DENABLE_PRESAGE=$(usex presage)
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_DOC=$(usex doc)
+ -DUSE_SYSTEMD=$(usex systemd)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
+
+src_test() {
+ # break by sandbox
+ local CMAKE_SKIP_TESTS=(
+ testdbus
+ testservicewatcher
+ )
+ cmake_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog
+ elog "Follow the instrcutions on:"
+ elog "https://wiki.gentoo.org/wiki/Fcitx#Using_Fcitx"
+ elog "https://fcitx-im.org/wiki/Setup_Fcitx_5"
+ elog "https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland"
+ elog
+}