summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-10-03 22:56:24 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-10-03 22:58:18 +0900
commit3cc3ec936646e1f033e33ed457685a64b3af375f (patch)
tree1aa256a5486ed50e0438ff472042eb611cee4c1d /app-i18n
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-3cc3ec936646e1f033e33ed457685a64b3af375f.tar.gz
gentoo-3cc3ec936646e1f033e33ed457685a64b3af375f.tar.bz2
gentoo-3cc3ec936646e1f033e33ed457685a64b3af375f.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 2b36752e5ae4..bad7a7ee8bb2 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.24.0.tar.gz 12225906 BLAKE2B 0f783054bb7da452ed46073b925d1138b3f5cf9c56c67939af9a1b0a374082fe6a2a86474c72173244e84f5458d030dd4fa1123cad5a96d7c83a2a6765304746 SHA512 15e1869f547e3285352c3d18d248102c6427fe7866554337c40748697bbf58df196441f593de8c89f04268952efe0349995ee8c9ffc072880470d383c6861258
DIST ibus-typing-booster-2.24.1.tar.gz 12218815 BLAKE2B dcc7e08d41d7a98bf1b7e14fa38bafeaa10427126d400d04b478724eb91039da11d1bd2332d1e081d140f916c77dd3a6fc0eddcb7d7797f3a8d5b0607808b8fb SHA512 e05a42f442db8047415336485ab88405f3abb221e05fc882505e423587905002d8c0d616b208e4f1cfdcfea7bc27bcab5ffe57eb06aaa10650bae062d114505e
+DIST ibus-typing-booster-2.24.2.tar.gz 12216471 BLAKE2B 069faa9340d79676c124451af09d020116894b3bc9bc5c8aed229d7315a2fb0222822c00974d5ac4fbe8410640a3b4f3ca0a6c73d8c9b1f52bc7411e8b372026 SHA512 6eb2cc058ce86ba0ffdb0261abf39d36340b3bf1cb7ef68af0db59b00fb7e739a5638e2090761acdce812382354bb3debd37ca44162dbf92a074499fcfd20d55
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.2.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.2.ebuild
new file mode 100644
index 000000000000..564f684f9809
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.24.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}